Read the docs
TI-2026-15337 Aliases CVE-2026-18712GHSA-jpw7-w4h8-xcfw

Incorrect authorization in MongoDB Server

Priority LOW 31CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-863.

Summary

An issue in MongoDB Server's Queryable Encryption maintenance operations could allow an authenticated user with privileges on one encrypted collection to cause unauthorized modification or destruction of data belonging to a different collection. This is due to insufficient validation of certain internal metadata references before they are used to perform operations on other namespaces.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00237 14th percentileScored 2026-11-07
Fix Fixed MongoDB Server (MongoDB): 8.3.8, 8.0.29, 7.0.40

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MongoDBMongoDB Server8.3.0 to before 8.3.8; 8.0 to before 8.0.29; 7.0 to before 7.0.408.3.8, 8.0.29, 7.0.40Patch availableCNA
  • MongoDB Server VendorMongoDB Affected 8.3.0 to before 8.3.8; 8.0 to before 8.0.29; 7.0 to before 7.0.40 Fixed in 8.3.8, 8.0.29, 7.0.40 Patch available CNA

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:*7.0.0 to before 7.0.40; 8.0.0 to before 8.0.29; 8.2.0 – 8.2.12; 8.3.0 to before 8.3.8VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:9.0.0:alpha0:*:*:-:-:*:*9.0.0 alpha0VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:9.0.0:alpha1:*:*:-:-:*:*9.0.0 alpha1VulnerableMongoDB
cpe:2.3:a:mongodb:mongodb:9.1.0:alpha0:*:*:-:-:*:*9.1.0 alpha0VulnerableMongoDB
  • cpe:2.3:a:mongodb:mongodb:*:*:*:*:*:*:*:* Versions 7.0.0 to before 7.0.40; 8.0.0 to before 8.0.29; 8.2.0 – 8.2.12; 8.3.0 to before 8.3.8 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:9.0.0:alpha0:*:*:-:-:*:* Versions 9.0.0 alpha0 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:9.0.0:alpha1:*:*:-:-:*:* Versions 9.0.0 alpha1 Vulnerable ·MongoDB
  • cpe:2.3:a:mongodb:mongodb:9.1.0:alpha0:*:*:-:-:*:* Versions 9.1.0 alpha0 Vulnerable ·MongoDB

Remediation

  • Fix · CNA MongoDB Server (MongoDB) Fixed in 8.3.8, 8.0.29, 7.0.40

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    MongoDB Server 7.0.40, 8.0.29, 8.3.8

    17 records Highest priority Priority MEDIUM 2 MEDIUM, 15 LOW

    Other records, highest priority first

    • TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongosPriority MEDIUM 44
    • TI-2026-15316 Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential ExposurePriority MEDIUM 41
    • TI-2026-15318 Out-of-bounds write in MongoDB ServerPriority LOW 32

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-18712
  2. 2026-10-03 Alias added: GHSA-jpw7-w4h8-xcfw

References

  • TI-2025-13542 Zlib compressed protocol header length confusion may allow memory read KEVCVSS 4.0HIGH 8.7
  • TI-2013-01669 MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the… CVSS 2.0MEDIUM 6.0
  • TI-2026-56639 Uncontrolled Resource Consumption in MongoDB Sharded Cluster Router Allows Unauthenticated Denial of Service CVSS 4.0HIGH 8.7
  • TI-2026-56628 Reachable assertion in MongoDB Server CVSS 4.0HIGH 8.7
  • TI-2026-15322 Improper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos CVSS 4.0HIGH 8.7
  • TI-2026-08537 Unbounded recursion in BSONColumn interleaved-reference causes pre-auth stack overflow CVSS 4.0HIGH 8.7
See all 187 →

Sources