Password Change Bypass via Auth Switch Endpoint
Priority LOW 16CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Mattermost versions 10.11.x <= 10.11.10 fail to validate user's authentication method when processing account auth type switch which allows an authenticated attacker to change account password without confirmation via falsely claiming a different auth provider.. Mattermost Advisory ID: MMSA-2026-00583
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00154 4th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 11.4.0, 10.11.11github.com/mattermost/mattermost/server/v8 (Go): 8.0.0-20260127144908-ced9a56e3988+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 10.11.0 – 10.11.10 | 11.4.0, 10.11.11 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20260127144908-ced9a56e3988 | 8.0.0-20260127144908-ced9a56e3988 | Patch available | GHSA-rv67-7w2g-7976 |
| — | github.com/mattermost/mattermost-server (Go) | before 5.3.2-0.20260127144908-ced9a56e3988 | 5.3.2-0.20260127144908-ced9a56e3988 | Patch available | GHSA-rv67-7w2g-7976 |
| — | github.com/mattermost/mattermost-server (Go) | 10.11.0-rc1 to before 10.11.11 | 10.11.11 | Patch available | GHSA-rv67-7w2g-7976 |
| — | github.com/mattermost/mattermost-server (Go) | 11.2.0-rc1 to before 11.2.3 | 11.2.3 | Patch available | GHSA-rv67-7w2g-7976 |
| — | github.com/mattermost/mattermost-server (Go) | 11.3.0-rc1 to before 11.3.1 | 11.3.1 | Patch available | GHSA-rv67-7w2g-7976 |
- Mattermost VendorMattermost Affected 10.11.0 – 10.11.10 Fixed in 11.4.0, 10.11.11 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20260127144908-ced9a56e3988 Fixed in 8.0.0-20260127144908-ced9a56e3988 Patch available GHSA-rv67-7w2g-7976
- github.com/mattermost/mattermost-server (Go) Vendor— Affected before 5.3.2-0.20260127144908-ced9a56e3988 Fixed in 5.3.2-0.20260127144908-ced9a56e3988 Patch available GHSA-rv67-7w2g-7976
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.11.0-rc1 to before 10.11.11 Fixed in 10.11.11 Patch available GHSA-rv67-7w2g-7976
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.2.0-rc1 to before 11.2.3 Fixed in 11.2.3 Patch available GHSA-rv67-7w2g-7976
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.3.0-rc1 to before 11.3.1 Fixed in 11.3.1 Patch available GHSA-rv67-7w2g-7976
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 10.11.0 to before 10.11.11 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.11.0 to before 10.11.11 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 11.4.0, 10.11.11
- Fix · GHSA-rv67-7w2g-7976 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20260127144908-ced9a56e3988 Advisory →
- Fix · GHSA-rv67-7w2g-7976 github.com/mattermost/mattermost-server (Go) Fixed in 5.3.2-0.20260127144908-ced9a56e3988 Advisory →
- Fix · GHSA-rv67-7w2g-7976 github.com/mattermost/mattermost-server (Go) Fixed in 10.11.11 Advisory →
- Fix · GHSA-rv67-7w2g-7976 github.com/mattermost/mattermost-server (Go) Fixed in 11.2.3 Advisory →
- Fix · GHSA-rv67-7w2g-7976 github.com/mattermost/mattermost-server (Go) Fixed in 11.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-22545
- 2026-10-03 Alias added: GHSA-rv67-7w2g-7976
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-22545 · CVE Program
- CVE-2026-22545 · NVD
- FIRST EPSS
- GHSA-rv67-7w2g-7976 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences