ElementsKit Elementor Addons < 3.7.9 Unauthenticated Mailchimp REST Endpoint
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-306.
Summary
ElementsKit Elementor Addons – Advanced Widgets & Templates Addons for Elementor (elementskit-lite) WordPress plugin versions prior to 3.7.9 expose the REST endpoint /wp-json/elementskit/v1/widget/mailchimp/subscribe without authentication. The endpoint accepts client-supplied Mailchimp API credentials and insufficiently validates certain parameters, including the list parameter, when constructing upstream Mailchimp API requests. An unauthenticated attacker can abuse the endpoint as an open proxy to Mailchimp, potentially triggering unauthorized API calls, manipulating subscription data, exhausting API quotas, or causing resource consumption on the affected WordPress site.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| roxnor | ElementsKit Elementor Addons – Advanced Widgets & Templates Addons for Elementor | before 3.7.9 | 3.7.9 | Patch available | CNA |
- ElementsKit Elementor Addons – Advanced Widgets & Templates Addons for Elementor Vendorroxnor Affected before 3.7.9 Fixed in 3.7.9 Patch available CNA
Remediation
- Fix · CNA ElementsKit Elementor Addons – Advanced Widgets & Templates Addons for Elementor (Roxnor) Fixed in 3.7.9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23693
- 2026-10-03 Alias added: GHSA-pc7w-r272-4xgr
References
More roxnor vulnerabilities
- TI-2022-01323 Metform Elementor Contact Form Builder <= 2.1.3 - Sensitive Information Disclosure CVSS 3.1HIGH 7.5
- TI-2023-00080 Metform Elementor Contact Form Builder <= 3.1.2 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
- TI-2022-00697 WP Fundraising Donation and Crowdfunding Platform < 1.5.0 - Unauthenticated SQLi CVSS 3.1CRITICAL 9.8
- TI-2026-51983 WordPress FundEngine plugin <= 1.7.9 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-27806 WordPress Metform Elementor Contact Form Builder plugin <= 3.4.0 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2026-19850 WordPress MetForm Pro plugin <= 3.9.1 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.1
Sources
- CVE-2026-23693 · CVE Program
- CVE-2026-23693 · NVD
- FIRST EPSS
- GHSA-pc7w-r272-4xgr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences