Orval MCP client is vulnerable to code injection via unsanitized x-enum-descriptions in enum generation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
Orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Versions prior to 7.19.0 until 8.0.2 are vulnerable to arbitrary code execution in environments consuming generated clients. This issue is similar in nature to CVE-2026-22785, but affects a different code path in @orval/core that was not addressed by CVE-2026-22785's fix. The vulnerability allows untrusted OpenAPI specifications to inject arbitrary TypeScript/JavaScript code into generated clients via the x-enumDescriptions field, which is embedded without proper escaping in getEnumImplementation(). I have confirmed that the injection occurs during const enum generation and results in executable code within the generated schema files. Orval 7.19.0 and 8.0.2 contain a fix for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| orval-labs | orval | 8.0.0-rc.0 to before 8.0.2; before 7.19.0 | 8.0.2, 7.19.0 | Patch available | CNA |
| — | @orval/core (npm) | 8.0.0-rc.0 to before 8.0.2 | 8.0.2 | Patch available | GHSA-h526-wf6g-67jv |
| — | @orval/core (npm) | before 7.19.0 | 7.19.0 | Patch available | GHSA-h526-wf6g-67jv |
- orval Vendororval-labs Affected 8.0.0-rc.0 to before 8.0.2; before 7.19.0 Fixed in 8.0.2, 7.19.0 Patch available CNA
- @orval/core (npm) Vendor— Affected 8.0.0-rc.0 to before 8.0.2 Fixed in 8.0.2 Patch available GHSA-h526-wf6g-67jv
- @orval/core (npm) Vendor— Affected before 7.19.0 Fixed in 7.19.0 Patch available GHSA-h526-wf6g-67jv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:orval:orval:*:*:*:*:*:*:*:* | before 7.19.0; 8.0.0 to before 8.0.2 | Vulnerable | orval-labs |
- cpe:2.3:a:orval:orval:*:*:*:*:*:*:*:* Versions before 7.19.0; 8.0.0 to before 8.0.2 Vulnerable ·orval-labs
Remediation
- Fix · CNA orval (orval-labs) Fixed in 8.0.2, 7.19.0
- Fix · GHSA-h526-wf6g-67jv @orval/core (npm) Fixed in 8.0.2 Advisory →
- Fix · GHSA-h526-wf6g-67jv @orval/core (npm) Fixed in 7.19.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23947
- 2026-10-03 Alias added: GHSA-h526-wf6g-67jv
References
Advisory 2
More orval-labs Orval vulnerabilities
- TI-2026-20303 Orval has a code injection via unsanitized x-enum-descriptions uing JS comments CVSS 4.0CRITICAL 9.3
- TI-2026-18303 orval MCP client is vulnerable to a code injection attack. CVSS 4.0CRITICAL 9.3
- TI-2026-19450 Orval Mock Generation Code Injection via const CVSS 4.0HIGH 7.7
Sources
- CVE-2026-23947 · CVE Program
- CVE-2026-23947 · NVD
- FIRST EPSS
- GHSA-h526-wf6g-67jv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences