Orval has a code injection via unsanitized x-enum-descriptions uing JS comments
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Versions starting with 7.19.0 and prior to 7.21.0 and 8.2.0 have an incomplete fix for CVE-2026-23947. While the jsStringEscape function properly handles single quotes ('), double quotes (") and so on, it is still possible to achieve code injection using only a limited set of characters that are currently not escaped. The vulnerability lies in the fact that the application can be forced to execute arbitrary JavaScript using characters such as []()!+. By using a technique known as JSFuck, an attacker can bypass the current sanitization logic and run arbitrary code without needing any alphanumeric characters or quotes. Version 7.21.0 and 8.2.0 contain an updated fix.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| orval-labs | orval | 7.19.0 to before 7.21.0; 8.0.0 to before 8.2.0 | 7.21.0, 8.2.0 | Patch available | CNA |
| — | @orval/core (npm) | 7.19.0 to before 7.21.0 | 7.21.0 | Patch available | GHSA-gch2-phqh-fg9q |
| — | @orval/core (npm) | 8.0.0 to before 8.2.0 | 8.2.0 | Patch available | GHSA-gch2-phqh-fg9q |
- orval Vendororval-labs Affected 7.19.0 to before 7.21.0; 8.0.0 to before 8.2.0 Fixed in 7.21.0, 8.2.0 Patch available CNA
- @orval/core (npm) Vendor— Affected 7.19.0 to before 7.21.0 Fixed in 7.21.0 Patch available GHSA-gch2-phqh-fg9q
- @orval/core (npm) Vendor— Affected 8.0.0 to before 8.2.0 Fixed in 8.2.0 Patch available GHSA-gch2-phqh-fg9q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:orval:orval:*:*:*:*:*:*:*:* | 7.19.0 to before 7.21.0; 8.0.0 to before 8.2.0 | Vulnerable | orval-labs |
- cpe:2.3:a:orval:orval:*:*:*:*:*:*:*:* Versions 7.19.0 to before 7.21.0; 8.0.0 to before 8.2.0 Vulnerable ·orval-labs
Remediation
- Fix · CNA orval (orval-labs) Fixed in 7.21.0, 8.2.0
- Fix · GHSA-gch2-phqh-fg9q @orval/core (npm) Fixed in 7.21.0 Advisory →
- Fix · GHSA-gch2-phqh-fg9q @orval/core (npm) Fixed in 8.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25141
- 2026-10-03 Alias added: GHSA-gch2-phqh-fg9q
References
Advisory 3
More orval-labs Orval vulnerabilities
- TI-2026-19289 Orval MCP client is vulnerable to code injection via unsanitized x-enum-descriptions in enum generation CVSS 4.0CRITICAL 9.3
- TI-2026-18303 orval MCP client is vulnerable to a code injection attack. CVSS 4.0CRITICAL 9.3
- TI-2026-19450 Orval Mock Generation Code Injection via const CVSS 4.0HIGH 7.7
Sources
- CVE-2026-25141 · CVE Program
- CVE-2026-25141 · NVD
- FIRST EPSS
- GHSA-gch2-phqh-fg9q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences