Backstage has a Possible SSRF when reading from allowed URL's in `backend.reading.allow`
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-918 and the CVSS impact.
Summary
Backstage is an open framework for building developer portals, and @backstage/backend-defaults provides the default implementations and setup for a standard Backstage backend app. Prior to versions 0.12.2, 0.13.2, 0.14.1, and 0.15.0, the `FetchUrlReader` component, used by the catalog and other plugins to fetch content from URLs, followed HTTP redirects automatically. This allowed an attacker who controls a host listed in `backend.reading.allow` to redirect requests to internal or sensitive URLs that are not on the allowlist, bypassing the URL allowlist security control. This is a Server-Side Request Forgery (SSRF) vulnerability that could allow access to internal resources, but it does not allow attackers to include additional request headers. This vulnerability is fixed in `@backstage/backend-defaults` version 0.12.2, 0.13.2, 0.14.1, and 0.15.0. Users should upgrade to this version or later. Some workarounds are available. Restrict `backend.reading.allow` to only trusted hosts that you control and that do not issue redirects, ensure allowed hosts do not have open redirect vulnerabilities, and/or use network-level controls to block access from Backstage to sensitive internal endpoints.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | backstage | before 0.12.2; 0.13.0 to before 0.13.2; 0.14.0 to before 0.14.1 | 0.12.2, 0.13.2, 0.14.1 | Patch available | CNA |
| — | @backstage/backend-defaults (npm) | before 0.12.2 | 0.12.2 | Patch available | GHSA-q2x5-4xjx-c6p9 |
| — | @backstage/backend-defaults (npm) | 0.13.0 to before 0.13.2 | 0.13.2 | Patch available | GHSA-q2x5-4xjx-c6p9 |
| — | @backstage/backend-defaults (npm) | 0.14.0 to before 0.14.1 | 0.14.1 | Patch available | GHSA-q2x5-4xjx-c6p9 |
- backstage Vendorbackstage Affected before 0.12.2; 0.13.0 to before 0.13.2; 0.14.0 to before 0.14.1 Fixed in 0.12.2, 0.13.2, 0.14.1 Patch available CNA
- @backstage/backend-defaults (npm) Vendor— Affected before 0.12.2 Fixed in 0.12.2 Patch available GHSA-q2x5-4xjx-c6p9
- @backstage/backend-defaults (npm) Vendor— Affected 0.13.0 to before 0.13.2 Fixed in 0.13.2 Patch available GHSA-q2x5-4xjx-c6p9
- @backstage/backend-defaults (npm) Vendor— Affected 0.14.0 to before 0.14.1 Fixed in 0.14.1 Patch available GHSA-q2x5-4xjx-c6p9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:linuxfoundation:backstage\/backend_defaults:*:*:*:*:*:node.js:*:* | before 0.12.2; 0.13.0 – 0.13.2; 0.14.0 – 0.14.1 | Vulnerable | backstage |
- cpe:2.3:a:linuxfoundation:backstage\/backend_defaults:*:*:*:*:*:node.js:*:* Versions before 0.12.2; 0.13.0 – 0.13.2; 0.14.0 – 0.14.1 Vulnerable ·backstage
Remediation
- Fix · CNA backstage (backstage) Fixed in 0.12.2, 0.13.2, 0.14.1
- Fix · GHSA-q2x5-4xjx-c6p9 @backstage/backend-defaults (npm) Fixed in 0.12.2 Advisory →
- Fix · GHSA-q2x5-4xjx-c6p9 @backstage/backend-defaults (npm) Fixed in 0.13.2 Advisory →
- Fix · GHSA-q2x5-4xjx-c6p9 @backstage/backend-defaults (npm) Fixed in 0.14.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Developer Hub 1 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-24048
- 2026-10-03 Alias added: GHSA-q2x5-4xjx-c6p9
- 2026-10-27 Affected versions changed · Red Hat
References
More Backstage/backend Defaults vulnerabilities
- TI-2026-69069 Improper input validation in Backstage cloud storage URL readers CVSS 3.1MEDIUM 4.9
Sources
- CVE-2026-24048 · CVE Program
- CVE-2026-24048 · NVD
- FIRST EPSS
- GHSA-q2x5-4xjx-c6p9 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-24048 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences