Read the docs
TI-2026-19688 Aliases CVE-2026-24421GHSA-wm8h-26fv-mg7g

phpMyFAQ missing authorization exposes /api/setup/backup to any authenticated user

Priority LOW 32CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

phpMyFAQ is an open source FAQ web application. Versions 4.0.16 and below have flawed authorization logic which exposes the /api/setup/backup endpoint to any authenticated user despite their permissions. SetupController.php uses userIsAuthenticated() but does not verify that the requester has configuration/admin permissions. Non-admin users can trigger a configuration backup and retrieve its path. The endpoint only checks authentication, not authorization, and returns a link to the generated ZIP. This issue is fixed in version 4.0.17.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01744 77th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpMyFAQ (thorsten): 4.0.17phpmyfaq/phpmyfaq (Packagist): 4.0.17+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
thorstenphpMyFAQbefore 4.0.174.0.17Patch availableCNA
—phpmyfaq/phpmyfaq (Packagist)before 4.0.174.0.17Patch availableGHSA-wm8h-26fv-mg7g
—thorsten/phpmyfaq (Packagist)before 4.0.174.0.17Patch availableGHSA-wm8h-26fv-mg7g
  • phpMyFAQ Vendorthorsten Affected before 4.0.17 Fixed in 4.0.17 Patch available CNA
  • phpmyfaq/phpmyfaq (Packagist) Vendor— Affected before 4.0.17 Fixed in 4.0.17 Patch available GHSA-wm8h-26fv-mg7g
  • thorsten/phpmyfaq (Packagist) Vendor— Affected before 4.0.17 Fixed in 4.0.17 Patch available GHSA-wm8h-26fv-mg7g

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:*before 4.0.17Vulnerablethorsten
  • cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:* Versions before 4.0.17 Vulnerable ·thorsten

Remediation

  • Fix · CNA phpMyFAQ (thorsten) Fixed in 4.0.17
  • Fix · GHSA-wm8h-26fv-mg7g phpmyfaq/phpmyfaq (Packagist) Fixed in 4.0.17 Advisory →
  • Fix · GHSA-wm8h-26fv-mg7g thorsten/phpmyfaq (Packagist) Fixed in 4.0.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-24421
  2. 2026-10-03 Alias added: GHSA-wm8h-26fv-mg7g

References

  • TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
  • TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
  • TI-2025-37331 phpMyFAQ duplicate email registration allows multiple accounts with the same email CVSS 3.1CRITICAL 9.8
  • TI-2024-36257 phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available CVSS 3.1HIGH 8.6
  • TI-2023-03720 Improper Neutralization of Formula Elements in a CSV File in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
  • TI-2023-00749 Command Injection in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
See all 153 →

Sources