Read the docs
TI-2026-19689 Aliases CVE-2026-24422GHSA-j4rc-96xj-gvqc

phpMyFAQ: Public API endpoints expose emails and invisible questions

Priority HIGH 72CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

phpMyFAQ is an open source FAQ web application. In versions 4.0.16 and below, multiple public API endpoints improperly expose sensitive user information due to insufficient access controls. The OpenQuestionController::list() endpoint calls Question::getAll() with showAll=true by default, returning records marked as non-public (isVisible=false) along with user email addresses, with similar exposures present in comment, news, and FAQ APIs. This information disclosure vulnerability could enable attackers to harvest email addresses for phishing campaigns or access content that was explicitly marked as private. This issue has been fixed in version 4.0.17.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00408 35th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpMyFAQ (thorsten): 4.0.17phpmyfaq/phpmyfaq (Packagist): 4.0.17+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
thorstenphpMyFAQbefore 4.0.174.0.17Patch availableCNA
—phpmyfaq/phpmyfaq (Packagist)before 4.0.174.0.17Patch availableGHSA-j4rc-96xj-gvqc
—thorsten/phpmyfaq (Packagist)before 4.0.174.0.17Patch availableGHSA-j4rc-96xj-gvqc
  • phpMyFAQ Vendorthorsten Affected before 4.0.17 Fixed in 4.0.17 Patch available CNA
  • phpmyfaq/phpmyfaq (Packagist) Vendor— Affected before 4.0.17 Fixed in 4.0.17 Patch available GHSA-j4rc-96xj-gvqc
  • thorsten/phpmyfaq (Packagist) Vendor— Affected before 4.0.17 Fixed in 4.0.17 Patch available GHSA-j4rc-96xj-gvqc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:*before 4.0.17Vulnerablethorsten
  • cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:* Versions before 4.0.17 Vulnerable ·thorsten

Remediation

  • Fix · CNA phpMyFAQ (thorsten) Fixed in 4.0.17
  • Fix · GHSA-j4rc-96xj-gvqc phpmyfaq/phpmyfaq (Packagist) Fixed in 4.0.17 Advisory →
  • Fix · GHSA-j4rc-96xj-gvqc thorsten/phpmyfaq (Packagist) Fixed in 4.0.17 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-24422
  2. 2026-10-03 Alias added: GHSA-j4rc-96xj-gvqc

References

  • TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
  • TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
  • TI-2025-37331 phpMyFAQ duplicate email registration allows multiple accounts with the same email CVSS 3.1CRITICAL 9.8
  • TI-2024-36257 phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available CVSS 3.1HIGH 8.6
  • TI-2023-03720 Improper Neutralization of Formula Elements in a CSV File in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
  • TI-2023-00749 Command Injection in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
See all 153 →

Sources