DotNetNuke.Core Vulnerable to Stored XSS in Module Deletion Confirmation Modal
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Starting in version 9.0.0 and prior to versions 9.13.10 and 10.2.0, a module friendly name could include scripts that will run during some module operations in the Persona Bar. Versions 9.13.10 and 10.2.0 contain a fix for the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| DotNetNuke (DNN) | Dnn.Platform | 9.0.0 to before 9.13.10; 10.0.0 to before 10.2.0 | 9.13.10, 10.2.0 | Patch available | CNA |
| — | DotNetNuke.Core (NuGet) | 9.0.0 – 9.13.9 | — | No fix listed | GHSA-vm5q-8qww-h238 |
| — | DotNetNuke.Core (NuGet) | 10.0.0 to before 10.2.0 | 10.2.0 | Patch available | GHSA-vm5q-8qww-h238 |
- Dnn.Platform VendorDotNetNuke (DNN) Affected 9.0.0 to before 9.13.10; 10.0.0 to before 10.2.0 Fixed in 9.13.10, 10.2.0 Patch available CNA
- DotNetNuke.Core (NuGet) Vendor— Affected 9.0.0 – 9.13.9 Fixed in — No fix listed GHSA-vm5q-8qww-h238
- DotNetNuke.Core (NuGet) Vendor— Affected 10.0.0 to before 10.2.0 Fixed in 10.2.0 Patch available GHSA-vm5q-8qww-h238
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dnnsoftware:dotnetnuke:*:*:*:*:*:*:*:* | 9.0.0 to before 9.13.10; 10.0.0 to before 10.2.0 | Vulnerable | DotNetNuke (DNN) |
- cpe:2.3:a:dnnsoftware:dotnetnuke:*:*:*:*:*:*:*:* Versions 9.0.0 to before 9.13.10; 10.0.0 to before 10.2.0 Vulnerable ·DotNetNuke (DNN)
Remediation
- Fix · CNA Dnn.Platform (dnnsoftware) Fixed in 9.13.10, 10.2.0
- Fix · GHSA-vm5q-8qww-h238 DotNetNuke.Core (NuGet) Fixed in 10.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-24837
- 2026-10-03 Alias added: GHSA-vm5q-8qww-h238
References
More DotNetNuke (DNN) Dotnetnuke vulnerabilities
- TI-2017-07201 Code injection in DotNetNuke CMS Fixed in 9.1.1 KEVCVSS 3.1HIGH 8.8
- TI-2018-12944 DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input… KEVCVSS 3.1HIGH 7.5
- TI-2018-11271 DNN (aka DotNetNuke) 9.2 through 9.2.1 uses a weak encryption algorithm to protect input parameters. KEVCVSS 3.1HIGH 7.5
- TI-2015-02468 The installation wizard in DotNetNuke (DNN) before 7.4.1 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2025-39546 DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite CVSS 3.1CRITICAL 10.0
- TI-2018-12945 DNN (aka DotNetNuke) 9.2 through 9.2.2 incorrectly converts encryption key source values… CVSS 3.1HIGH 7.5
Sources
- CVE-2026-24837 · CVE Program
- CVE-2026-24837 · NVD
- FIRST EPSS
- GHSA-vm5q-8qww-h238 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences