strongSwan 4.5.0 < 6.0.5 EAP-TTLS AVP Parsing Integer Underflow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-191 and the CVSS impact.
Summary
strongSwan versions 4.5.0 prior to 6.0.5 contain an integer underflow vulnerability in the EAP-TTLS AVP parser that allows unauthenticated remote attackers to cause a denial of service by sending crafted AVP data with invalid length fields during IKEv2 authentication. Attackers can exploit the failure to validate AVP length fields before subtraction to trigger excessive memory allocation or NULL pointer dereference, crashing the charon IKE daemon.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| strongSwan | strongSwan | 4.5.0 to before 6.0.5 | 6.0.5 | Patch available | CNA |
- strongSwan VendorstrongSwan Affected 4.5.0 to before 6.0.5 Fixed in 6.0.5 Patch available CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:strongswan:strongswan:*:*:*:*:*:*:*:* | — | — | strongSwan |
- cpe:2.3:a:strongswan:strongswan:*:*:*:*:*:*:*:* Versions — — ·strongSwan
Remediation
- Fix · CNA strongSwan (strongSwan) Fixed in 6.0.5
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25075
- 2026-10-03 Alias added: GHSA-frr2-5qjr-h4hw
References
More strongSwan vulnerabilities
- TI-2023-22300 strongSwan before 5.9.12 has a buffer overflow and possible unauthenticated remote code… CVSS 3.1CRITICAL 9.8
- TI-2015-03374 strongSwan 5.2.2 and 5.3.0 allows remote attackers to cause a denial of service (daemon… CVSS 3.0CRITICAL 9.8
- TI-2004-00531 FreeS/WAN 1.x and 2.x, and other related products including superfreeswan 1.x, openswan… CVSS 2.0HIGH 10.0
- TI-2023-11610 strongSwan 5.9.8 and 5.9.9 potentially allows remote code execution because it uses a… CVSS 3.1CRITICAL 9.8
- TI-2026-21012 strongMan vulnerable to private credential recovery due to key and counter reuse CVSS 4.0HIGH 8.7
- TI-2021-20414 In strongSwan before 5.9.5, a malicious responder can send an EAP-Success message too… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2026-25075 · CVE Program
- CVE-2026-25075 · NVD
- FIRST EPSS
- GHSA-frr2-5qjr-h4hw · GitHub Advisory Database · CC BY 4.0
- CVE-2026-25075 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences