Read the docs
TI-2026-20256 Aliases CVE-2026-25076GHSA-qgpf-49hm-qfx7

Anchore Enterprise GraphQL Reports API SQL injection

Priority LOW 39CWE-89Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.

Summary

Anchore Enterprise versions before 5.25.1 contain an SQL injection vulnerability in the GraphQL Reports API. An authenticated attacker that is able to access the GraphQL API could execute arbitrary SQL instructions resulting in modifications to the data contained in the Anchore Enterprise database.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00343 27th percentileScored 2026-11-07
Fix Fixed Anchore Enterprise (Anchore): 5.25.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
anchoreAnchore Enterprisebefore 5.25.15.25.1Patch availableCNA
  • Anchore Enterprise Vendoranchore Affected before 5.25.1 Fixed in 5.25.1 Patch available CNA

Remediation

  • Fix · CNA Anchore Enterprise (Anchore) Fixed in 5.25.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-25076
  2. 2026-10-03 Alias added: GHSA-qgpf-49hm-qfx7

References

  • TI-2024-16200 Tar path traversal in stereoscope when processing OCI tar archives CVSS 3.1CRITICAL 9.8
  • TI-2023-10327 Credential disclosure in syft when SYFT_ATTEST_PASSWORD environment variable set in syft CVSS 3.1HIGH 7.5
  • TI-2020-08949 Shell Escape in Anchore Engine CVSS 3.1CRITICAL 9.9
  • TI-2026-45314 Anchore Enterprise Privilege Escalation via User Management API CVSS 4.0HIGH 8.7
  • TI-2025-40533 Grype has a credential disclosure vulnerability in Grype JSON output CVSS 4.0HIGH 8.2
  • TI-2022-01632 Insufficiently protected credentials in Anchore Enterprise CVSS 3.1HIGH 7.5
See all 11 →

Sources