Wagtail has improper permission handling on admin preview endpoints
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Wagtail is an open source content management system built on Django. Prior to versions 6.3.6, 7.0.4, 7.1.3, 7.2.2, and 7.3, due to a missing permission check on the preview endpoints, a user with access to the Wagtail admin and knowledge of a model's fields can craft a form submission to obtain a preview rendering of any page, snippet or site setting object for which previews are enabled, consisting of any data of the user's choosing. The existing data of the object itself is not exposed, but depending on the nature of the template being rendered, this may expose other database contents that would otherwise only be accessible to users with edit access over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.6, 7.0.4, 7.1.3, 7.2.2, and 7.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wagtail | wagtail | before 6.3.6; 6.4rc1 to before 7.0.4; 7.1rc1 to before 7.1.3; 7.2rc1 to before 7.2.2; = 7.3rc1 | 6.3.6, 7.0.4, 7.1.3, 7.2.2 | Patch available | CNA |
| — | wagtail (PyPI) | before 6.3.6 | 6.3.6 | Patch available | GHSA-4qvv-g3vr-m348 |
| — | wagtail (PyPI) | 6.4rc1 to before 7.0.4 | 7.0.4 | Patch available | GHSA-4qvv-g3vr-m348 |
| — | wagtail (PyPI) | 7.1rc1 to before 7.1.3 | 7.1.3 | Patch available | GHSA-4qvv-g3vr-m348 |
| — | wagtail (PyPI) | 7.2rc1 to before 7.2.2 | 7.2.2 | Patch available | GHSA-4qvv-g3vr-m348 |
| — | wagtail (PyPI) | 7.3rc1 to before 7.3 | 7.3 | Patch available | GHSA-4qvv-g3vr-m348 |
- wagtail Vendorwagtail Affected before 6.3.6; 6.4rc1 to before 7.0.4; 7.1rc1 to before 7.1.3; 7.2rc1 to before 7.2.2; = 7.3rc1 Fixed in 6.3.6, 7.0.4, 7.1.3, 7.2.2 Patch available CNA
- wagtail (PyPI) Vendor— Affected before 6.3.6 Fixed in 6.3.6 Patch available GHSA-4qvv-g3vr-m348
- wagtail (PyPI) Vendor— Affected 6.4rc1 to before 7.0.4 Fixed in 7.0.4 Patch available GHSA-4qvv-g3vr-m348
- wagtail (PyPI) Vendor— Affected 7.1rc1 to before 7.1.3 Fixed in 7.1.3 Patch available GHSA-4qvv-g3vr-m348
- wagtail (PyPI) Vendor— Affected 7.2rc1 to before 7.2.2 Fixed in 7.2.2 Patch available GHSA-4qvv-g3vr-m348
- wagtail (PyPI) Vendor— Affected 7.3rc1 to before 7.3 Fixed in 7.3 Patch available GHSA-4qvv-g3vr-m348
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:torchbox:wagtail:*:*:*:*:*:*:*:* | before 6.3.6; 6.4 to before 7.0.4; 7.1 to before 7.1.3; 7.2 to before 7.2.2 | Vulnerable | wagtail |
- cpe:2.3:a:torchbox:wagtail:*:*:*:*:*:*:*:* Versions before 6.3.6; 6.4 to before 7.0.4; 7.1 to before 7.1.3; 7.2 to before 7.2.2 Vulnerable ·wagtail
Remediation
- Fix · CNA wagtail (wagtail) Fixed in 6.3.6, 7.0.4, 7.1.3, 7.2.2
- Fix · GHSA-4qvv-g3vr-m348 wagtail (PyPI) Fixed in 6.3.6 Advisory →
- Fix · GHSA-4qvv-g3vr-m348 wagtail (PyPI) Fixed in 7.0.4 Advisory →
- Fix · GHSA-4qvv-g3vr-m348 wagtail (PyPI) Fixed in 7.1.3 Advisory →
- Fix · GHSA-4qvv-g3vr-m348 wagtail (PyPI) Fixed in 7.2.2 Advisory →
- Fix · GHSA-4qvv-g3vr-m348 wagtail (PyPI) Fixed in 7.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25517
- 2026-10-03 Alias added: GHSA-4qvv-g3vr-m348
References
Patch 5
- https://github.com/wagtail/wagtail/commit/01fd3477365a193e6a8270311defb76e890d2719
- https://github.com/wagtail/wagtail/commit/5f09b6da61e779b0e8499bdbba52bf2f7bd3241f
- https://github.com/wagtail/wagtail/commit/73f070dbefbd3b39ea6649ce36bd2d2a6eef2190
- https://github.com/wagtail/wagtail/commit/7dfe8de5f8b3f112c73c87b6729197db16454915
- https://github.com/wagtail/wagtail/commit/dd824023a031f1b82a6b6f83a97a5c73391b7c03
Advisory 2
Other 6
- https://github.com/wagtail/wagtail
- https://github.com/wagtail/wagtail/releases/tag/v6.3.6
- https://github.com/wagtail/wagtail/releases/tag/v7.0.4
- https://github.com/wagtail/wagtail/releases/tag/v7.1.3
- https://github.com/wagtail/wagtail/releases/tag/v7.2.2
- https://github.com/wagtail/wagtail/releases/tag/v7.3
More Wagtail vulnerabilities
- TI-2026-39163 Wagtail: Reflected XSS in dynamic image URL generator view CVSS 3.1HIGH 7.3
- TI-2020-08875 Possible XSS attack in Wagtail CVSS 3.1MEDIUM 6.8
- TI-2023-13342 Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views CVSS 3.1MEDIUM 6.4
- TI-2026-32180 Wagtail: Improper restriction handling on Documents and Images API CVSS 3.1MEDIUM 5.3
- TI-2026-22558 Wagtail: Improper escaping of HTML (Cross-site Scripting) in simple_translation admin interface CVSS 3.1MEDIUM 6.1
- TI-2026-22557 Wagtail: Improper escaping of HTML (Cross-site Scripting) on TableBlock class attributes CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-25517 · CVE Program
- CVE-2026-25517 · NVD
- FIRST EPSS
- GHSA-4qvv-g3vr-m348 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences