Denial of service via malformed User-Agent header in getBrowserVersion
Priority LOW 20CWE-1287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2, 10.11.x <= 10.11.10 fail to properly validate User-Agent header tokens which allows an authenticated attacker to cause a request panic via a specially crafted User-Agent header. Mattermost Advisory ID: MMSA-2026-00586
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00303 23rd percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 11.4.0, 11.3.1, 11.2.3 +1github.com/mattermost/mattermost/server/v8 (Go): 8.0.0-20260129181235-1346cf529aef+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 11.3.0 – 11.3.0; 11.2.0 – 11.2.2; 10.11.0 – 10.11.10 | 11.4.0, 11.3.1, 11.2.3, 10.11.11 | Patch available | CNA |
| — | github.com/mattermost/mattermost/server/v8 (Go) | before 8.0.0-20260129181235-1346cf529aef | 8.0.0-20260129181235-1346cf529aef | Patch available | GHSA-2v3w-6g35-5f9v |
| — | github.com/mattermost/mattermost-server (Go) | before 5.3.2-0.20260129181235-1346cf529aef | 5.3.2-0.20260129181235-1346cf529aef | Patch available | GHSA-2v3w-6g35-5f9v |
| — | github.com/mattermost/mattermost-server (Go) | 10.11.0-rc1 to before 10.11.11 | 10.11.11 | Patch available | GHSA-2v3w-6g35-5f9v |
| — | github.com/mattermost/mattermost-server (Go) | 11.2.0-rc1 to before 11.2.3 | 11.2.3 | Patch available | GHSA-2v3w-6g35-5f9v |
| — | github.com/mattermost/mattermost-server (Go) | 11.3.0-rc1 to before 11.3.1 | 11.3.1 | Patch available | GHSA-2v3w-6g35-5f9v |
- Mattermost VendorMattermost Affected 11.3.0 – 11.3.0; 11.2.0 – 11.2.2; 10.11.0 – 10.11.10 Fixed in 11.4.0, 11.3.1, 11.2.3, 10.11.11 Patch available CNA
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected before 8.0.0-20260129181235-1346cf529aef Fixed in 8.0.0-20260129181235-1346cf529aef Patch available GHSA-2v3w-6g35-5f9v
- github.com/mattermost/mattermost-server (Go) Vendor— Affected before 5.3.2-0.20260129181235-1346cf529aef Fixed in 5.3.2-0.20260129181235-1346cf529aef Patch available GHSA-2v3w-6g35-5f9v
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.11.0-rc1 to before 10.11.11 Fixed in 10.11.11 Patch available GHSA-2v3w-6g35-5f9v
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.2.0-rc1 to before 11.2.3 Fixed in 11.2.3 Patch available GHSA-2v3w-6g35-5f9v
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.3.0-rc1 to before 11.3.1 Fixed in 11.3.1 Patch available GHSA-2v3w-6g35-5f9v
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 10.11.0 to before 10.11.11; 11.2.0 to before 11.2.3; 11.3.0 to before 11.3.1 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.11.0 to before 10.11.11; 11.2.0 to before 11.2.3; 11.3.0 to before 11.3.1 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 11.4.0, 11.3.1, 11.2.3, 10.11.11
- Fix · GHSA-2v3w-6g35-5f9v github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20260129181235-1346cf529aef Advisory →
- Fix · GHSA-2v3w-6g35-5f9v github.com/mattermost/mattermost-server (Go) Fixed in 5.3.2-0.20260129181235-1346cf529aef Advisory →
- Fix · GHSA-2v3w-6g35-5f9v github.com/mattermost/mattermost-server (Go) Fixed in 10.11.11 Advisory →
- Fix · GHSA-2v3w-6g35-5f9v github.com/mattermost/mattermost-server (Go) Fixed in 11.2.3 Advisory →
- Fix · GHSA-2v3w-6g35-5f9v github.com/mattermost/mattermost-server (Go) Fixed in 11.3.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25783
- 2026-10-03 Alias added: GHSA-2v3w-6g35-5f9v
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-25783 · CVE Program
- CVE-2026-25783 · NVD
- FIRST EPSS
- GHSA-2v3w-6g35-5f9v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences