Read the docs
TI-2026-20982 Aliases CVE-2026-25957GHSA-9vph-2hvm-x66g

Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request

Priority LOW 29CWE-755Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Cube is a semantic layer for building data applications. From 1.1.17 to before 1.5.13 and 1.4.2, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. This vulnerability is fixed in 1.5.13 and 1.4.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00434 37th percentileScored 2026-11-07
Fix Fixed cube (cube-js): 1.4.2, 1.5.13@cubejs-backend/server-core (npm): 1.4.2, 1.5.13

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
cube-jscube1.1.17 to before 1.4.2; 1.5.0 to before 1.5.131.4.2, 1.5.13Patch availableCNA
—@cubejs-backend/server-core (npm)1.1.17 to before 1.4.21.4.2Patch availableGHSA-9vph-2hvm-x66g
—@cubejs-backend/server-core (npm)1.5.0 to before 1.5.131.5.13Patch availableGHSA-9vph-2hvm-x66g
  • cube Vendorcube-js Affected 1.1.17 to before 1.4.2; 1.5.0 to before 1.5.13 Fixed in 1.4.2, 1.5.13 Patch available CNA
  • @cubejs-backend/server-core (npm) Vendor— Affected 1.1.17 to before 1.4.2 Fixed in 1.4.2 Patch available GHSA-9vph-2hvm-x66g
  • @cubejs-backend/server-core (npm) Vendor— Affected 1.5.0 to before 1.5.13 Fixed in 1.5.13 Patch available GHSA-9vph-2hvm-x66g

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:cube:cube.js:*:*:*:*:*:node.js:*:*1.1.17 to before 1.4.2; 1.5.0 to before 1.5.13Vulnerablecube-js
  • cpe:2.3:a:cube:cube.js:*:*:*:*:*:node.js:*:* Versions 1.1.17 to before 1.4.2; 1.5.0 to before 1.5.13 Vulnerable ·cube-js

Remediation

  • Fix · CNA cube (cube-js) Fixed in 1.4.2, 1.5.13
  • Fix · GHSA-9vph-2hvm-x66g @cubejs-backend/server-core (npm) Fixed in 1.4.2 Advisory →
  • Fix · GHSA-9vph-2hvm-x66g @cubejs-backend/server-core (npm) Fixed in 1.5.13 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-25957
  2. 2026-10-03 Alias added: GHSA-9vph-2hvm-x66g

References

  • TI-2022-07569 SQl injection in cube-js CVSS 3.1CRITICAL 9.6
  • TI-2026-20983 Cube privilege escalation via a specially crafted request CVSS 3.1HIGH 7.7
  • TI-2023-27655 Denial of service attack on the cube-api endpoint CVSS 3.1HIGH 7.5

Sources