Cube privilege escalation via a specially crafted request
Priority LOW 34CWE-807Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00382 32nd percentileScored 2026-11-07
Fix Fixed cube (cube-js): 1.0.14, 1.4.2, 1.5.13@cubejs-backend/server-core (npm): 1.0.14, 1.4.2, 1.5.13
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| cube-js | cube | 0.27.19 to before 1.0.14; 1.1.0 to before 1.4.2; 1.5.0 to before 1.5.13 | 1.0.14, 1.4.2, 1.5.13 | Patch available | CNA |
| — | @cubejs-backend/server-core (npm) | 0.27.19 to before 1.0.14 | 1.0.14 | Patch available | GHSA-v226-32c7-x2v7 |
| — | @cubejs-backend/server-core (npm) | 1.1.0 to before 1.4.2 | 1.4.2 | Patch available | GHSA-v226-32c7-x2v7 |
| — | @cubejs-backend/server-core (npm) | 1.5.0 to before 1.5.13 | 1.5.13 | Patch available | GHSA-v226-32c7-x2v7 |
- cube Vendorcube-js Affected 0.27.19 to before 1.0.14; 1.1.0 to before 1.4.2; 1.5.0 to before 1.5.13 Fixed in 1.0.14, 1.4.2, 1.5.13 Patch available CNA
- @cubejs-backend/server-core (npm) Vendor— Affected 0.27.19 to before 1.0.14 Fixed in 1.0.14 Patch available GHSA-v226-32c7-x2v7
- @cubejs-backend/server-core (npm) Vendor— Affected 1.1.0 to before 1.4.2 Fixed in 1.4.2 Patch available GHSA-v226-32c7-x2v7
- @cubejs-backend/server-core (npm) Vendor— Affected 1.5.0 to before 1.5.13 Fixed in 1.5.13 Patch available GHSA-v226-32c7-x2v7
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cube:cube.js:*:*:*:*:*:node.js:*:* | 0.27.19 to before 1.0.14; 1.1.0 to before 1.4.2; 1.5.0 to before 1.5.13 | Vulnerable | cube-js |
- cpe:2.3:a:cube:cube.js:*:*:*:*:*:node.js:*:* Versions 0.27.19 to before 1.0.14; 1.1.0 to before 1.4.2; 1.5.0 to before 1.5.13 Vulnerable ·cube-js
Remediation
- Fix · CNA cube (cube-js) Fixed in 1.0.14, 1.4.2, 1.5.13
- Fix · GHSA-v226-32c7-x2v7 @cubejs-backend/server-core (npm) Fixed in 1.0.14 Advisory →
- Fix · GHSA-v226-32c7-x2v7 @cubejs-backend/server-core (npm) Fixed in 1.4.2 Advisory →
- Fix · GHSA-v226-32c7-x2v7 @cubejs-backend/server-core (npm) Fixed in 1.5.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-25958
- 2026-10-03 Alias added: GHSA-v226-32c7-x2v7
References
More cube-js Cube.js vulnerabilities
- TI-2022-07569 SQl injection in cube-js CVSS 3.1CRITICAL 9.6
- TI-2023-27655 Denial of service attack on the cube-api endpoint CVSS 3.1HIGH 7.5
- TI-2026-20982 Cube Denial of Service (DoS) - An authenticated attacker can crash the server by sending a specially crafted request CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-25958 · CVE Program
- CVE-2026-25958 · NVD
- FIRST EPSS
- GHSA-v226-32c7-x2v7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences