Permission Bypass in Playbook Run Creation
Priority LOW 19CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Mattermost versions 11.3.x <= 11.3.0, 11.2.x <= 11.2.2 fail to verify run_create permission for empty playbookId, which allows team members to create unauthorized runs via the playbook run API. Mattermost Advisory ID: MMSA-2025-00542
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00169 6th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 11.4.0, 11.3.1, 11.2.3github.com/mattermost/mattermost-plugin-playbooks (Go): 1.41.1-0.20260316224925-705f54a81841
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 11.3.0 – 11.3.0; 11.2.0 – 11.2.2 | 11.4.0, 11.3.1, 11.2.3 | Patch available | CNA |
| — | github.com/mattermost/mattermost-plugin-playbooks (Go) | before 1.41.1-0.20260316224925-705f54a81841 | 1.41.1-0.20260316224925-705f54a81841 | Patch available | GHSA-4pmx-622h-x359 |
- Mattermost VendorMattermost Affected 11.3.0 – 11.3.0; 11.2.0 – 11.2.2 Fixed in 11.4.0, 11.3.1, 11.2.3 Patch available CNA
- github.com/mattermost/mattermost-plugin-playbooks (Go) Vendor— Affected before 1.41.1-0.20260316224925-705f54a81841 Fixed in 1.41.1-0.20260316224925-705f54a81841 Patch available GHSA-4pmx-622h-x359
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | 11.2.0 to before 11.2.3; 11.3.0 to before 11.3.1 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 11.2.0 to before 11.2.3; 11.3.0 to before 11.3.1 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 11.4.0, 11.3.1, 11.2.3
- Fix · GHSA-4pmx-622h-x359 github.com/mattermost/mattermost-plugin-playbooks (Go) Fixed in 1.41.1-0.20260316224925-705f54a81841 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-26304
- 2026-10-03 Alias added: GHSA-4pmx-622h-x359
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-26304 · CVE Program
- CVE-2026-26304 · NVD
- FIRST EPSS
- GHSA-4pmx-622h-x359 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences