Improper Validation of Array Index in Packetbeat Leading to Denial of Service
Key facts
- Attack vector
- Adjacent network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-129 and the CVSS impact.
Summary
Improper Validation of Array Index (CWE-129) in multiple protocol parser components in Packetbeat can lead Denial of Service via Input Data Manipulation (CAPEC-153). An attacker with the ability to send specially crafted, malformed network packets to a monitored network interface can trigger out-of-bounds read operations, resulting in application crashes or resource exhaustion. This requires the attacker to be positioned on the same network segment as the Packetbeat deployment or to control traffic routed to monitored interfaces.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Packetbeat | 9.0.0 – 9.2.4; 8.0.0 – 8.19.10 | — | No fix listed | CNA |
| — | github.com/elastic/beats/v7 (Go) | before 7.0.0-alpha2.0.20260126223743-dec1b31111ec | 7.0.0-alpha2.0.20260126223743-dec1b31111ec | Patch available | GHSA-27qj-9gvp-8rh9 |
- Packetbeat VendorElastic Affected 9.0.0 – 9.2.4; 8.0.0 – 8.19.10 Fixed in — No fix listed CNA
- github.com/elastic/beats/v7 (Go) Vendor— Affected before 7.0.0-alpha2.0.20260126223743-dec1b31111ec Fixed in 7.0.0-alpha2.0.20260126223743-dec1b31111ec Patch available GHSA-27qj-9gvp-8rh9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:elasticsearch:packetbeat:*:*:*:*:*:*:*:* | 8.0.0 to before 8.19.11; 9.0.0 to before 9.2.5 | Vulnerable | Elasticsearch |
- cpe:2.3:a:elasticsearch:packetbeat:*:*:*:*:*:*:*:* Versions 8.0.0 to before 8.19.11; 9.0.0 to before 9.2.5 Vulnerable ·Elasticsearch
Remediation
- Fix · GHSA-27qj-9gvp-8rh9 github.com/elastic/beats/v7 (Go) Fixed in 7.0.0-alpha2.0.20260126223743-dec1b31111ec Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-26933
- 2026-10-03 Alias added: GHSA-27qj-9gvp-8rh9
References
Advisory 2
More Elastic vulnerabilities
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
- TI-2018-12328 Kibana versions before 6.4.3 and 5.6.13 contain an arbitrary file inclusion flaw in the… CVSS 3.0CRITICAL 9.8
- TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
- TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-26933 · CVE Program
- CVE-2026-26933 · NVD
- FIRST EPSS
- GHSA-27qj-9gvp-8rh9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences