WordPress Royal Elementor Addons plugin < 1.7.1053 - Cross Site Scripting (XSS) vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WProyal Royal Elementor Addons allows Stored XSS. This issue affects Royal Elementor Addons: from n/a before 1.7.1053.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Royal Elementor Addons (WProyal) Fixed in 1.7.1053
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WProyal Royal Elementor Addons 1.7.1053
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-20550 WordPress Royal Elementor Addons plugin < 1.7.1053 - Broken Access Control vulnerabilityPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2026-27421
- 2026-10-03 Alias added: GHSA-h3xh-5g78-fc7p
More wproyal vulnerabilities
- TI-2023-04933 Royal Elementor Addons and Templates < 1.3.79 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
- TI-2023-05454 Royal Elementor Addons and Templates < 1.3.81 - Unauthenticated Arbitrary Post Read CVSS 3.1HIGH 7.5
- TI-2022-03751 Royal Elementor Addons < 1.3.56 - Subscriber+ Arbitrary Post Creation CVSS 3.1MEDIUM 4.3
- TI-2024-01463 Royal Elementor Addons and Templates <= 1.3.94 - Unauthenticated Limited File Upload CVSS 3.1CRITICAL 9.8
- TI-2024-21660 WordPress Royal Elementor Addons and Templates plugin <= 1.3.93 - IP Bypass vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-03750 Royal Elementor Addons < 1.3.56 - Subscriber+ Arbitrary Post Deletion CVSS 3.1LOW 3.1
Sources
- CVE-2026-27421 · CVE Program
- CVE-2026-27421 · NVD
- FIRST EPSS
- GHSA-h3xh-5g78-fc7p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences