Read the docs
TI-2026-22038 Aliases CVE-2026-27656GHSA-fg35-5rf6-qg3g

Account Takeover via Substring Matching in OpenID Connect Authentication

Priority LOW 28CWE-303Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to properly validate user identity in the OpenID {{IsSameUser()}} comparison logic, which allows an attacker to take over arbitrary user accounts via an overly permissive substring matching flaw in the user discovery flow.. Mattermost Advisory ID: MMSA-2026-00590

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00183 7th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 11.5.0, 11.4.1, 11.3.2 +2github.com/mattermost/mattermost-server (Go): 11.4.1, 11.3.2, 11.2.4 +1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
MattermostMattermost11.4.0 – 11.4.0; 11.3.0 – 11.3.1; 11.2.0 – 11.2.3; 10.11.0 – 10.11.1111.5.0, 11.4.1, 11.3.2, 11.2.4, 10.11.12Patch availableCNA
—github.com/mattermost/mattermost-server (Go)11.4.0-rc1 to before 11.4.111.4.1Patch availableGHSA-fg35-5rf6-qg3g
—github.com/mattermost/mattermost-server (Go)11.3.0-rc1 to before 11.3.211.3.2Patch availableGHSA-fg35-5rf6-qg3g
—github.com/mattermost/mattermost-server (Go)11.2.0-rc1 to before 11.2.411.2.4Patch availableGHSA-fg35-5rf6-qg3g
—github.com/mattermost/mattermost-server (Go)10.11.0-rc1 to before 10.11.1210.11.12Patch availableGHSA-fg35-5rf6-qg3g
—github.com/mattermost/mattermost/server/v8 (Go)8.0.0-20260105080200-d27a2195068d to before 8.0.0-20260217110922-b7d4a1f1f59b8.0.0-20260217110922-b7d4a1f1f59bPatch availableGHSA-fg35-5rf6-qg3g
  • Mattermost VendorMattermost Affected 11.4.0 – 11.4.0; 11.3.0 – 11.3.1; 11.2.0 – 11.2.3; 10.11.0 – 10.11.11 Fixed in 11.5.0, 11.4.1, 11.3.2, 11.2.4, 10.11.12 Patch available CNA
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.4.0-rc1 to before 11.4.1 Fixed in 11.4.1 Patch available GHSA-fg35-5rf6-qg3g
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.3.0-rc1 to before 11.3.2 Fixed in 11.3.2 Patch available GHSA-fg35-5rf6-qg3g
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 11.2.0-rc1 to before 11.2.4 Fixed in 11.2.4 Patch available GHSA-fg35-5rf6-qg3g
  • github.com/mattermost/mattermost-server (Go) Vendor— Affected 10.11.0-rc1 to before 10.11.12 Fixed in 10.11.12 Patch available GHSA-fg35-5rf6-qg3g
  • github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 8.0.0-20260105080200-d27a2195068d to before 8.0.0-20260217110922-b7d4a1f1f59b Fixed in 8.0.0-20260217110922-b7d4a1f1f59b Patch available GHSA-fg35-5rf6-qg3g

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:*10.11.0 to before 10.11.12; 11.2.0 to before 11.2.4; 11.3.0 to before 11.3.2; 11.4.0 to before 11.4.1VulnerableMattermost
  • cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions 10.11.0 to before 10.11.12; 11.2.0 to before 11.2.4; 11.3.0 to before 11.3.2; 11.4.0 to before 11.4.1 Vulnerable ·Mattermost

Remediation

  • Fix · CNA Mattermost (Mattermost) Fixed in 11.5.0, 11.4.1, 11.3.2, 11.2.4, 10.11.12
  • Fix · GHSA-fg35-5rf6-qg3g github.com/mattermost/mattermost-server (Go) Fixed in 11.4.1 Advisory →
  • Fix · GHSA-fg35-5rf6-qg3g github.com/mattermost/mattermost-server (Go) Fixed in 11.3.2 Advisory →
  • Fix · GHSA-fg35-5rf6-qg3g github.com/mattermost/mattermost-server (Go) Fixed in 11.2.4 Advisory →
  • Fix · GHSA-fg35-5rf6-qg3g github.com/mattermost/mattermost-server (Go) Fixed in 10.11.12 Advisory →
  • Fix · GHSA-fg35-5rf6-qg3g github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.0-20260217110922-b7d4a1f1f59b Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-27656
  2. 2026-10-03 Alias added: GHSA-fg35-5rf6-qg3g

References

  • TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
  • TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
  • TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
  • TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
  • TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
  • TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
See all 505 →

Sources