Read the docs
TI-2026-22080 Aliases CVE-2026-27704

Dart SDK and Flutter SDK have Zip slip in Dart Pub package extraction

Priority LOW 29CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.

Summary

The Dart and Flutter SDKs provide software development kits for the Dart programming language. In versions of the Dart SDK prior to 3.11.0 and the Flutter SDK prior to version 3.41.0, when the pub client (`dart pub` and `flutter pub`) extracts a package in the pub cache, a malicious package archive can have files extracted outside the destination directory in the `PUB_CACHE`. A fix has been landed in commit 26c6985c742593d081f8b58450f463a584a4203a. By normalizing the file path before writing file, the attacker can no longer traverse up via a symlink. This patch is released in Dart 3.11.0 and Flutter 3.41.0.vAll packages on pub.dev have been vetted for this vulnerability. New packages are no longer allowed to contain symlinks. The pub client itself doesn't upload symlinks, but duplicates the linked entry, and has been doing this for years. Those whose dependencies are all from pub.dev, third-party repositories trusted to not contain malicious code, or git dependencies are not affected by this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00408 35th percentileScored 2026-11-07
Fix Fixed sdk (dart-lang): 3.11.0flutter (dart-lang): 3.41.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
dart-langsdkbefore 3.11.03.11.0Patch availableCNA
dart-langflutterbefore 3.41.03.41.0Patch availableCNA
  • sdk Vendordart-lang Affected before 3.11.0 Fixed in 3.11.0 Patch available CNA
  • flutter Vendordart-lang Affected before 3.41.0 Fixed in 3.41.0 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:dart:dart_software_development_kit:*:*:*:*:*:*:*:*before 3.11.0VulnerableDart
cpe:2.3:a:flutter:flutter:*:*:*:*:*:*:*:*before 3.41.0VulnerableFlutter
  • cpe:2.3:a:dart:dart_software_development_kit:*:*:*:*:*:*:*:* Versions before 3.11.0 Vulnerable ·Dart
  • cpe:2.3:a:flutter:flutter:*:*:*:*:*:*:*:* Versions before 3.41.0 Vulnerable ·Flutter

Remediation

  • Fix · CNA sdk (dart-lang) Fixed in 3.11.0
  • Fix · CNA flutter (dart-lang) Fixed in 3.41.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-27704

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences