wpForo Forum 2.4.14 Stored XSS via Unsafe JSON Encoding in Inline Script
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
wpForo Forum 2.4.14 contains a stored cross-site scripting vulnerability that allows script injection via forum URL data output into an inline script block using json_encode without the JSON_HEX_TAG flag. Attackers set a forum slug containing a closing script tag or unescaped single quote to break out of the JavaScript string context and execute arbitrary script in all visitors' browsers.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| gVectors Team | wpForo Forum | 2.4 to before 2.4.16 | 2.4.16 | Patch available | CNA |
- wpForo Forum VendorgVectors Team Affected 2.4 to before 2.4.16 Fixed in 2.4.16 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gvectors:wpforo_forum:*:*:*:*:*:wordpress:*:* | 2.4.0 to before 2.4.16 | Vulnerable | gVectors Team |
- cpe:2.3:a:gvectors:wpforo_forum:*:*:*:*:*:wordpress:*:* Versions 2.4.0 to before 2.4.16 Vulnerable ·gVectors Team
Remediation
- Fix · CNA wpForo Forum (gVectors Team) Fixed in 2.4.16
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
gVectors Team wpForo Forum 2.4.16
8 records Highest priority Priority LOW 8 LOW
Other records, highest priority first
- TI-2026-22814 wpForo Forum 2.4.14 Information Disclosure via Global RSS FeedPriority LOW 37
- TI-2026-22812 wpForo Forum < 2.4.16 Privilege Escalation via Role Synchronization HandlerPriority LOW 33
- TI-2026-22811 wpForo Forum 2.4.14 Missing Authorization via Topic Management Form HandlersPriority LOW 24
Timeline
- 2026-10-02 Threatist record created from CVE-2026-28560
- 2026-10-03 Alias added: GHSA-qv3m-qhpr-9vhh
References
More gVectors Team Wpforo Forum vulnerabilities
- TI-2023-02108 Server-side request forgery in gVectors Team wpForo Forum CVSS 3.1HIGH 8.8
- TI-2023-02165 wpForo Forum < 2.1.9 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-25972 WordPress wpForo plugin <= 2.2.3 - Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
- TI-2018-11904 An issue was discovered in the update function in the wpForo Forum plugin before 1.5.2… CVSS 3.0CRITICAL 9.8
- TI-2026-22817 wpForo Forum 2.4.14 SQL Injection via Topics ORDER BY Parameter CVSS 4.0HIGH 8.8
- TI-2022-19066 WordPress wpForo Forum plugin <= 2.0.9 - Auth. Arbitrary File Upload vulnerability CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-28560 · CVE Program
- CVE-2026-28560 · NVD
- FIRST EPSS
- GHSA-qv3m-qhpr-9vhh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences