Parse Server: GraphQL `__type` introspection bypass via inline fragments when public introspection is disabled
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. From version 9.3.1-alpha.3 to before version 9.5.0-alpha.10, when graphQLPublicIntrospection is disabled, __type queries nested inside inline fragments (e.g. ... on Query { __type(name:"User") { name } }) bypass the introspection control, allowing unauthenticated users to perform type reconnaissance. __schema introspection is not affected. This issue has been patched in version 9.5.0-alpha.10.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | 9.3.1-alpha.3 to before 9.5.0-alpha.10 | 9.5.0-alpha.10 | Patch available | CNA |
| — | parse-server (npm) | 9.3.1-alpha.3 to before 9.5.0-alpha.10 | 9.5.0-alpha.10 | Patch available | GHSA-q5q9-2rhp-33qw |
- parse-server Vendorparse-community Affected 9.3.1-alpha.3 to before 9.5.0-alpha.10 Fixed in 9.5.0-alpha.10 Patch available CNA
- parse-server (npm) Vendor— Affected 9.3.1-alpha.3 to before 9.5.0-alpha.10 Fixed in 9.5.0-alpha.10 Patch available GHSA-q5q9-2rhp-33qw
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | 9.4.0 to before 9.5.0 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.3.1:alpha3:*:*:*:node.js:*:* | 9.3.1 alpha3 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.3.1:alpha4:*:*:*:node.js:*:* | 9.3.1 alpha4 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha1:*:*:*:node.js:*:* | 9.5.0 alpha1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha2:*:*:*:node.js:*:* | 9.5.0 alpha2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha3:*:*:*:node.js:*:* | 9.5.0 alpha3 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha4:*:*:*:node.js:*:* | 9.5.0 alpha4 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha5:*:*:*:node.js:*:* | 9.5.0 alpha5 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha6:*:*:*:node.js:*:* | 9.5.0 alpha6 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha7:*:*:*:node.js:*:* | 9.5.0 alpha7 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions 9.4.0 to before 9.5.0 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.3.1:alpha3:*:*:*:node.js:*:* Versions 9.3.1 alpha3 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.3.1:alpha4:*:*:*:node.js:*:* Versions 9.3.1 alpha4 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha1:*:*:*:node.js:*:* Versions 9.5.0 alpha1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha2:*:*:*:node.js:*:* Versions 9.5.0 alpha2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha3:*:*:*:node.js:*:* Versions 9.5.0 alpha3 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha4:*:*:*:node.js:*:* Versions 9.5.0 alpha4 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha5:*:*:*:node.js:*:* Versions 9.5.0 alpha5 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha6:*:*:*:node.js:*:* Versions 9.5.0 alpha6 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha7:*:*:*:node.js:*:* Versions 9.5.0 alpha7 Vulnerable ·parse-community
Show 2 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha8:*:*:*:node.js:*:* | 9.5.0 alpha8 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha9:*:*:*:node.js:*:* | 9.5.0 alpha9 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha8:*:*:*:node.js:*:* Versions 9.5.0 alpha8 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha9:*:*:*:node.js:*:* Versions 9.5.0 alpha9 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 9.5.0-alpha.10
- Fix · GHSA-q5q9-2rhp-33qw parse-server (npm) Fixed in 9.5.0-alpha.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-30854
- 2026-10-03 Alias added: GHSA-q5q9-2rhp-33qw
References
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-30854 · CVE Program
- CVE-2026-30854 · NVD
- FIRST EPSS
- GHSA-q5q9-2rhp-33qw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences