Parse Server: JWT audience validation bypass in Google, Apple, and Facebook authentication adapters
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.10 and 9.5.0-alpha.11, the Google, Apple, and Facebook authentication adapters use JWT verification to validate identity tokens. When the adapter's audience configuration option is not set (clientId for Google/Apple, appIds for Facebook), JWT verification silently skips audience claim validation. This allows an attacker to use a validly signed JWT issued for a different application to authenticate as any user on the target Parse Server. This issue has been patched in versions 8.6.10 and 9.5.0-alpha.11.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | before 8.6.10; before 9.5.0-alpha.11 | 8.6.10, 9.5.0-alpha.11 | Patch available | CNA |
| — | parse-server (npm) | 9.0.0-alpha.1 to before 9.5.0-alpha.11 | 9.5.0-alpha.11 | Patch available | GHSA-x6fw-778m-wr9v |
| — | parse-server (npm) | before 8.6.10 | 8.6.10 | Patch available | GHSA-x6fw-778m-wr9v |
- parse-server Vendorparse-community Affected before 8.6.10; before 9.5.0-alpha.11 Fixed in 8.6.10, 9.5.0-alpha.11 Patch available CNA
- parse-server (npm) Vendor— Affected 9.0.0-alpha.1 to before 9.5.0-alpha.11 Fixed in 9.5.0-alpha.11 Patch available GHSA-x6fw-778m-wr9v
- parse-server (npm) Vendor— Affected before 8.6.10 Fixed in 8.6.10 Patch available GHSA-x6fw-778m-wr9v
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 8.6.10; 9.0.0 to before 9.5.0 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha1:*:*:*:node.js:*:* | 9.5.0 alpha1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha10:*:*:*:node.js:*:* | 9.5.0 alpha10 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha2:*:*:*:node.js:*:* | 9.5.0 alpha2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha3:*:*:*:node.js:*:* | 9.5.0 alpha3 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha4:*:*:*:node.js:*:* | 9.5.0 alpha4 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha5:*:*:*:node.js:*:* | 9.5.0 alpha5 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha6:*:*:*:node.js:*:* | 9.5.0 alpha6 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha7:*:*:*:node.js:*:* | 9.5.0 alpha7 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha8:*:*:*:node.js:*:* | 9.5.0 alpha8 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.10; 9.0.0 to before 9.5.0 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha1:*:*:*:node.js:*:* Versions 9.5.0 alpha1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha10:*:*:*:node.js:*:* Versions 9.5.0 alpha10 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha2:*:*:*:node.js:*:* Versions 9.5.0 alpha2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha3:*:*:*:node.js:*:* Versions 9.5.0 alpha3 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha4:*:*:*:node.js:*:* Versions 9.5.0 alpha4 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha5:*:*:*:node.js:*:* Versions 9.5.0 alpha5 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha6:*:*:*:node.js:*:* Versions 9.5.0 alpha6 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha7:*:*:*:node.js:*:* Versions 9.5.0 alpha7 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha8:*:*:*:node.js:*:* Versions 9.5.0 alpha8 Vulnerable ·parse-community
Show 1 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha9:*:*:*:node.js:*:* | 9.5.0 alpha9 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:9.5.0:alpha9:*:*:*:node.js:*:* Versions 9.5.0 alpha9 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 8.6.10, 9.5.0-alpha.11
- Fix · GHSA-x6fw-778m-wr9v parse-server (npm) Fixed in 9.5.0-alpha.11 Advisory →
- Fix · GHSA-x6fw-778m-wr9v parse-server (npm) Fixed in 8.6.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-30863
- 2026-10-03 Alias added: GHSA-x6fw-778m-wr9v
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-30863 · CVE Program
- CVE-2026-30863 · NVD
- FIRST EPSS
- GHSA-x6fw-778m-wr9v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences