Parse Server affected by denial-of-service via unbounded query complexity in REST and GraphQL API
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior 9.5.2-alpha.2 and 8.6.15, an unauthenticated attacker can exhaust Parse Server resources (CPU, memory, database connections) through crafted queries that exploit the lack of complexity limits in the REST and GraphQL APIs. All Parse Server deployments using the REST or GraphQL API are affected. This vulnerability is fixed in 9.5.2-alpha.2 and 8.6.15.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | before 8.6.15; >= 9.0.0 < 9.5.2-alpha.2 | 8.6.15 | Patch available | CNA |
| — | parse-server (npm) | before 8.6.15 | 8.6.15 | Patch available | GHSA-cmj3-wx7h-ffvg |
| — | parse-server (npm) | 9.0.0 to before 9.5.2-alpha.2 | 9.5.2-alpha.2 | Patch available | GHSA-cmj3-wx7h-ffvg |
- parse-server Vendorparse-community Affected before 8.6.15; >= 9.0.0 < 9.5.2-alpha.2 Fixed in 8.6.15 Patch available CNA
- parse-server (npm) Vendor— Affected before 8.6.15 Fixed in 8.6.15 Patch available GHSA-cmj3-wx7h-ffvg
- parse-server (npm) Vendor— Affected 9.0.0 to before 9.5.2-alpha.2 Fixed in 9.5.2-alpha.2 Patch available GHSA-cmj3-wx7h-ffvg
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 8.6.15; 9.0.0 to before 9.5.2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha1:*:*:*:node.js:*:* | 9.5.2 alpha1 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.15; 9.0.0 to before 9.5.2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha1:*:*:*:node.js:*:* Versions 9.5.2 alpha1 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 8.6.15
- Fix · GHSA-cmj3-wx7h-ffvg parse-server (npm) Fixed in 8.6.15 Advisory →
- Fix · GHSA-cmj3-wx7h-ffvg parse-server (npm) Fixed in 9.5.2-alpha.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-30946
- 2026-10-03 Alias added: GHSA-cmj3-wx7h-ffvg
- 2026-10-07 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-30946 · CVE Program
- CVE-2026-30946 · NVD
- FIRST EPSS
- GHSA-cmj3-wx7h-ffvg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences