Parse Server is missing audience validation in Keycloak authentication adapter
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.5 and 8.6.18, the Keycloak authentication adapter does not validate the azp (authorized party) claim of Keycloak access tokens against the configured client-id. A valid access token issued by the same Keycloak realm for a different client application can be used to authenticate as any user on the Parse Server that uses the Keycloak adapter. This enables cross-application account takeover in multi-client Keycloak realms. All Parse Server deployments that use the Keycloak authentication adapter with a Keycloak realm that has multiple client applications are affected. This vulnerability is fixed in 9.5.2-alpha.5 and 8.6.18.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | >= 9.0.0 < 9.5.2-alpha.5; before 8.6.18 | 8.6.18 | Patch available | CNA |
| — | parse-server (npm) | 9.0.0 to before 9.5.2-alpha.5 | 9.5.2-alpha.5 | Patch available | GHSA-48mh-j4p5-7j9v |
| — | parse-server (npm) | before 8.6.18 | 8.6.18 | Patch available | GHSA-48mh-j4p5-7j9v |
- parse-server Vendorparse-community Affected >= 9.0.0 < 9.5.2-alpha.5; before 8.6.18 Fixed in 8.6.18 Patch available CNA
- parse-server (npm) Vendor— Affected 9.0.0 to before 9.5.2-alpha.5 Fixed in 9.5.2-alpha.5 Patch available GHSA-48mh-j4p5-7j9v
- parse-server (npm) Vendor— Affected before 8.6.18 Fixed in 8.6.18 Patch available GHSA-48mh-j4p5-7j9v
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 8.6.18; 9.0.0 to before 9.5.2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha1:*:*:*:node.js:*:* | 9.5.2 alpha1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha2:*:*:*:node.js:*:* | 9.5.2 alpha2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha3:*:*:*:node.js:*:* | 9.5.2 alpha3 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha4:*:*:*:node.js:*:* | 9.5.2 alpha4 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.18; 9.0.0 to before 9.5.2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha1:*:*:*:node.js:*:* Versions 9.5.2 alpha1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha2:*:*:*:node.js:*:* Versions 9.5.2 alpha2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha3:*:*:*:node.js:*:* Versions 9.5.2 alpha3 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha4:*:*:*:node.js:*:* Versions 9.5.2 alpha4 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 8.6.18
- Fix · GHSA-48mh-j4p5-7j9v parse-server (npm) Fixed in 9.5.2-alpha.5 Advisory →
- Fix · GHSA-48mh-j4p5-7j9v parse-server (npm) Fixed in 8.6.18 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-30949
- 2026-10-03 Alias added: GHSA-48mh-j4p5-7j9v
- 2026-10-08 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-30949 · CVE Program
- CVE-2026-30949 · NVD
- FIRST EPSS
- GHSA-48mh-j4p5-7j9v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences