Parse Server has a protected fields bypass via logical query operators
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | >= 9.0.0 < 9.5.2-alpha.6; before 8.6.19 | 8.6.19 | Patch available | CNA |
| — | parse-server (npm) | 9.0.0 to before 9.5.2-alpha.6 | 9.5.2-alpha.6 | Patch available | GHSA-72hp-qff8-4pvv |
| — | parse-server (npm) | before 8.6.19 | 8.6.19 | Patch available | GHSA-72hp-qff8-4pvv |
- parse-server Vendorparse-community Affected >= 9.0.0 < 9.5.2-alpha.6; before 8.6.19 Fixed in 8.6.19 Patch available CNA
- parse-server (npm) Vendor— Affected 9.0.0 to before 9.5.2-alpha.6 Fixed in 9.5.2-alpha.6 Patch available GHSA-72hp-qff8-4pvv
- parse-server (npm) Vendor— Affected before 8.6.19 Fixed in 8.6.19 Patch available GHSA-72hp-qff8-4pvv
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 8.6.19; 9.0.0 to before 9.5.2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha1:*:*:*:node.js:*:* | 9.5.2 alpha1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha2:*:*:*:node.js:*:* | 9.5.2 alpha2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha3:*:*:*:node.js:*:* | 9.5.2 alpha3 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha4:*:*:*:node.js:*:* | 9.5.2 alpha4 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha5:*:*:*:node.js:*:* | 9.5.2 alpha5 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.19; 9.0.0 to before 9.5.2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha1:*:*:*:node.js:*:* Versions 9.5.2 alpha1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha2:*:*:*:node.js:*:* Versions 9.5.2 alpha2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha3:*:*:*:node.js:*:* Versions 9.5.2 alpha3 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha4:*:*:*:node.js:*:* Versions 9.5.2 alpha4 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha5:*:*:*:node.js:*:* Versions 9.5.2 alpha5 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 8.6.19
- Fix · GHSA-72hp-qff8-4pvv parse-server (npm) Fixed in 9.5.2-alpha.6 Advisory →
- Fix · GHSA-72hp-qff8-4pvv parse-server (npm) Fixed in 8.6.19 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-30962
- 2026-10-03 Alias added: GHSA-72hp-qff8-4pvv
References
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-30962 · CVE Program
- CVE-2026-30962 · NVD
- FIRST EPSS
- GHSA-72hp-qff8-4pvv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences