Parse Server OAuth2 authentication adapter account takeover via identity spoofing
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.9. and 8.6.22, the OAuth2 authentication adapter, when configured without the useridField option, only verifies that a token is active via the provider's token introspection endpoint, but does not verify that the token belongs to the user identified by authData.id. An attacker with any valid OAuth2 token from the same provider can authenticate as any other user. This affects any Parse Server deployment that uses the generic OAuth2 authentication adapter (configured with oauth2: true) without setting the useridField option. This vulnerability is fixed in 9.5.2-alpha.9. and 8.6.22.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | >= 9.0.0 < 9.5.2-alpha.9; before 8.6.22 | 8.6.22 | Patch available | CNA |
| — | parse-server (npm) | 9.0.0-alpha.1 to before 9.5.2-alpha.9 | 9.5.2-alpha.9 | Patch available | GHSA-fr88-w35c-r596 |
| — | parse-server (npm) | before 8.6.22 | 8.6.22 | Patch available | GHSA-fr88-w35c-r596 |
- parse-server Vendorparse-community Affected >= 9.0.0 < 9.5.2-alpha.9; before 8.6.22 Fixed in 8.6.22 Patch available CNA
- parse-server (npm) Vendor— Affected 9.0.0-alpha.1 to before 9.5.2-alpha.9 Fixed in 9.5.2-alpha.9 Patch available GHSA-fr88-w35c-r596
- parse-server (npm) Vendor— Affected before 8.6.22 Fixed in 8.6.22 Patch available GHSA-fr88-w35c-r596
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 8.6.22; 9.0.0 to before 9.5.2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha1:*:*:*:node.js:*:* | 9.5.2 alpha1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha2:*:*:*:node.js:*:* | 9.5.2 alpha2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha3:*:*:*:node.js:*:* | 9.5.2 alpha3 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha4:*:*:*:node.js:*:* | 9.5.2 alpha4 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha5:*:*:*:node.js:*:* | 9.5.2 alpha5 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha6:*:*:*:node.js:*:* | 9.5.2 alpha6 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha7:*:*:*:node.js:*:* | 9.5.2 alpha7 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha8:*:*:*:node.js:*:* | 9.5.2 alpha8 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.22; 9.0.0 to before 9.5.2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha1:*:*:*:node.js:*:* Versions 9.5.2 alpha1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha2:*:*:*:node.js:*:* Versions 9.5.2 alpha2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha3:*:*:*:node.js:*:* Versions 9.5.2 alpha3 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha4:*:*:*:node.js:*:* Versions 9.5.2 alpha4 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha5:*:*:*:node.js:*:* Versions 9.5.2 alpha5 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha6:*:*:*:node.js:*:* Versions 9.5.2 alpha6 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha7:*:*:*:node.js:*:* Versions 9.5.2 alpha7 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha8:*:*:*:node.js:*:* Versions 9.5.2 alpha8 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 8.6.22
- Fix · GHSA-fr88-w35c-r596 parse-server (npm) Fixed in 9.5.2-alpha.9 Advisory →
- Fix · GHSA-fr88-w35c-r596 parse-server (npm) Fixed in 8.6.22 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-30967
- 2026-10-03 Alias added: GHSA-fr88-w35c-r596
- 2026-10-08 EPSS moved to the 50th–90th percentile
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-30967 · CVE Program
- CVE-2026-30967 · NVD
- FIRST EPSS
- GHSA-fr88-w35c-r596 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences