Parse Server has an LDAP injection via unsanitized user input in DN and group filter construction
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | >= 9.0.0 < 9.5.2-alpha.13; before 8.6.26 | 8.6.26 | Patch available | CNA |
| — | parse-server (npm) | 9.0.0-alpha.1 to before 9.5.2-alpha.13 | 9.5.2-alpha.13 | Patch available | GHSA-7m6r-fhh7-r47c |
| — | parse-server (npm) | before 8.6.26 | 8.6.26 | Patch available | GHSA-7m6r-fhh7-r47c |
- parse-server Vendorparse-community Affected >= 9.0.0 < 9.5.2-alpha.13; before 8.6.26 Fixed in 8.6.26 Patch available CNA
- parse-server (npm) Vendor— Affected 9.0.0-alpha.1 to before 9.5.2-alpha.13 Fixed in 9.5.2-alpha.13 Patch available GHSA-7m6r-fhh7-r47c
- parse-server (npm) Vendor— Affected before 8.6.26 Fixed in 8.6.26 Patch available GHSA-7m6r-fhh7-r47c
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 8.6.26; 9.0.0 to before 9.5.2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha1:*:*:*:node.js:*:* | 9.5.2 alpha1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha10:*:*:*:node.js:*:* | 9.5.2 alpha10 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha11:*:*:*:node.js:*:* | 9.5.2 alpha11 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha12:*:*:*:node.js:*:* | 9.5.2 alpha12 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha2:*:*:*:node.js:*:* | 9.5.2 alpha2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha3:*:*:*:node.js:*:* | 9.5.2 alpha3 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha4:*:*:*:node.js:*:* | 9.5.2 alpha4 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha5:*:*:*:node.js:*:* | 9.5.2 alpha5 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha6:*:*:*:node.js:*:* | 9.5.2 alpha6 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.26; 9.0.0 to before 9.5.2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha1:*:*:*:node.js:*:* Versions 9.5.2 alpha1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha10:*:*:*:node.js:*:* Versions 9.5.2 alpha10 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha11:*:*:*:node.js:*:* Versions 9.5.2 alpha11 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha12:*:*:*:node.js:*:* Versions 9.5.2 alpha12 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha2:*:*:*:node.js:*:* Versions 9.5.2 alpha2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha3:*:*:*:node.js:*:* Versions 9.5.2 alpha3 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha4:*:*:*:node.js:*:* Versions 9.5.2 alpha4 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha5:*:*:*:node.js:*:* Versions 9.5.2 alpha5 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha6:*:*:*:node.js:*:* Versions 9.5.2 alpha6 Vulnerable ·parse-community
Show 3 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha7:*:*:*:node.js:*:* | 9.5.2 alpha7 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha8:*:*:*:node.js:*:* | 9.5.2 alpha8 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha9:*:*:*:node.js:*:* | 9.5.2 alpha9 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha7:*:*:*:node.js:*:* Versions 9.5.2 alpha7 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha8:*:*:*:node.js:*:* Versions 9.5.2 alpha8 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.5.2:alpha9:*:*:*:node.js:*:* Versions 9.5.2 alpha9 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 8.6.26
- Fix · GHSA-7m6r-fhh7-r47c parse-server (npm) Fixed in 9.5.2-alpha.13 Advisory →
- Fix · GHSA-7m6r-fhh7-r47c parse-server (npm) Fixed in 8.6.26 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-31828
- 2026-10-03 Alias added: GHSA-7m6r-fhh7-r47c
- 2026-10-25 EPSS moved to the below the 50th percentile
References
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-31828 · CVE Program
- CVE-2026-31828 · NVD
- FIRST EPSS
- GHSA-7m6r-fhh7-r47c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences