Read the docs
TI-2026-24393 Aliases CVE-2026-31840GHSA-qpr4-jrj4-6f27

Parse Server has a SQL injection via dot-notation field name in PostgreSQL

Priority MEDIUM 49CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.2 and 8.6.28, an attacker can use a dot-notation field name in combination with the sort query parameter to inject SQL into the PostgreSQL database through an improper escaping of sub-field values in dot-notation queries. The vulnerability may also affect queries that use dot-notation field names with the distinct and where query parameters. This vulnerability only affects deployments using a PostgreSQL database. This vulnerability is fixed in 9.6.0-alpha.2 and 8.6.28.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00474 41st percentileScored 2026-11-07
Fix Fixed parse-server (parse-community): 8.6.28parse-server (npm): 9.6.0-alpha.2, 8.6.28

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
parse-communityparse-server>= 9.0.0 < 9.6.0-alpha.2; before 8.6.288.6.28Patch availableCNA
—parse-server (npm)9.0.0 to before 9.6.0-alpha.29.6.0-alpha.2Patch availableGHSA-qpr4-jrj4-6f27
—parse-server (npm)before 8.6.288.6.28Patch availableGHSA-qpr4-jrj4-6f27
  • parse-server Vendorparse-community Affected >= 9.0.0 < 9.6.0-alpha.2; before 8.6.28 Fixed in 8.6.28 Patch available CNA
  • parse-server (npm) Vendor— Affected 9.0.0 to before 9.6.0-alpha.2 Fixed in 9.6.0-alpha.2 Patch available GHSA-qpr4-jrj4-6f27
  • parse-server (npm) Vendor— Affected before 8.6.28 Fixed in 8.6.28 Patch available GHSA-qpr4-jrj4-6f27

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*before 8.6.28; 9.0.0 to before 9.6.0Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha1:*:*:*:node.js:*:*9.6.0 alpha1Vulnerableparse-community
  • cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.28; 9.0.0 to before 9.6.0 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha1:*:*:*:node.js:*:* Versions 9.6.0 alpha1 Vulnerable ·parse-community

Remediation

  • Fix · CNA parse-server (parse-community) Fixed in 8.6.28
  • Fix · GHSA-qpr4-jrj4-6f27 parse-server (npm) Fixed in 9.6.0-alpha.2 Advisory →
  • Fix · GHSA-qpr4-jrj4-6f27 parse-server (npm) Fixed in 8.6.28 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-31840
  2. 2026-10-03 Alias added: GHSA-qpr4-jrj4-6f27
  3. 2026-10-25 EPSS moved to the below the 50th percentile

References

  • TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
  • TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
  • TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
  • TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
  • TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
See all 101 →

Sources