Read the docs
TI-2026-24453 Aliases CVE-2026-31901GHSA-w54v-hf9p-8856

Parse Server has user enumeration via email verification endpoint

Priority LOW 28CWE-204Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-204.

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.34 and 9.6.0-alpha.8, the email verification endpoint (/verificationEmailRequest) returns distinct error responses depending on whether an email address belongs to an existing user, is already verified, or does not exist. An attacker can send requests with different email addresses and observe the error codes to determine which email addresses are registered in the application. This is a user enumeration vulnerability that affects any Parse Server deployment with email verification enabled (verifyUserEmails: true). This vulnerability is fixed in 8.6.34 and 9.6.0-alpha.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00277 20th percentileScored 2026-11-07
Fix Fixed parse-server (parse-community): 8.6.34parse-server (npm): 9.6.0-alpha.8, 8.6.34

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
parse-communityparse-server>= 9.0.0 < 9.6.0-alpha.8; before 8.6.348.6.34Patch availableCNA
—parse-server (npm)9.0.0-alpha.1 to before 9.6.0-alpha.89.6.0-alpha.8Patch availableGHSA-w54v-hf9p-8856
—parse-server (npm)before 8.6.348.6.34Patch availableGHSA-w54v-hf9p-8856
  • parse-server Vendorparse-community Affected >= 9.0.0 < 9.6.0-alpha.8; before 8.6.34 Fixed in 8.6.34 Patch available CNA
  • parse-server (npm) Vendor— Affected 9.0.0-alpha.1 to before 9.6.0-alpha.8 Fixed in 9.6.0-alpha.8 Patch available GHSA-w54v-hf9p-8856
  • parse-server (npm) Vendor— Affected before 8.6.34 Fixed in 8.6.34 Patch available GHSA-w54v-hf9p-8856

CPE configurations NVD · 8

CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*before 8.6.34; 9.0.0 to before 9.6.0Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha1:*:*:*:node.js:*:*9.6.0 alpha1Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha2:*:*:*:node.js:*:*9.6.0 alpha2Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha3:*:*:*:node.js:*:*9.6.0 alpha3Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha4:*:*:*:node.js:*:*9.6.0 alpha4Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha5:*:*:*:node.js:*:*9.6.0 alpha5Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha6:*:*:*:node.js:*:*9.6.0 alpha6Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha7:*:*:*:node.js:*:*9.6.0 alpha7Vulnerableparse-community
  • cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.34; 9.0.0 to before 9.6.0 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha1:*:*:*:node.js:*:* Versions 9.6.0 alpha1 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha2:*:*:*:node.js:*:* Versions 9.6.0 alpha2 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha3:*:*:*:node.js:*:* Versions 9.6.0 alpha3 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha4:*:*:*:node.js:*:* Versions 9.6.0 alpha4 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha5:*:*:*:node.js:*:* Versions 9.6.0 alpha5 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha6:*:*:*:node.js:*:* Versions 9.6.0 alpha6 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha7:*:*:*:node.js:*:* Versions 9.6.0 alpha7 Vulnerable ·parse-community

Remediation

  • Fix · CNA parse-server (parse-community) Fixed in 8.6.34
  • Fix · GHSA-w54v-hf9p-8856 parse-server (npm) Fixed in 9.6.0-alpha.8 Advisory →
  • Fix · GHSA-w54v-hf9p-8856 parse-server (npm) Fixed in 8.6.34 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-31901
  2. 2026-10-03 Alias added: GHSA-w54v-hf9p-8856

References

  • TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
  • TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
  • TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
  • TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
  • TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
See all 101 →

Sources