Parse Server has a protected fields bypass via LiveQuery subscription WHERE clause
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.9 and 8.6.35, an attacker can exploit LiveQuery subscriptions to infer the values of protected fields without directly receiving them. By subscribing with a WHERE clause that references a protected field (including via dot-notation or $regex), the attacker can observe whether LiveQuery events are delivered for matching objects. This creates a boolean oracle that leaks protected field values. The attack affects any class that has both protectedFields configured in Class-Level Permissions and LiveQuery enabled. This vulnerability is fixed in 9.6.0-alpha.9 and 8.6.35.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | >= 9.0.0 < 9.6.0-alpha.9; before 8.6.35 | 8.6.35 | Patch available | CNA |
| — | parse-server (npm) | 9.0.0 to before 9.6.0-alpha.9 | 9.6.0-alpha.9 | Patch available | GHSA-j7mm-f4rv-6q6q |
| — | parse-server (npm) | before 8.6.35 | 8.6.35 | Patch available | GHSA-j7mm-f4rv-6q6q |
- parse-server Vendorparse-community Affected >= 9.0.0 < 9.6.0-alpha.9; before 8.6.35 Fixed in 8.6.35 Patch available CNA
- parse-server (npm) Vendor— Affected 9.0.0 to before 9.6.0-alpha.9 Fixed in 9.6.0-alpha.9 Patch available GHSA-j7mm-f4rv-6q6q
- parse-server (npm) Vendor— Affected before 8.6.35 Fixed in 8.6.35 Patch available GHSA-j7mm-f4rv-6q6q
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 8.6.35; 9.0.0 to before 9.6.0 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha1:*:*:*:node.js:*:* | 9.6.0 alpha1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha2:*:*:*:node.js:*:* | 9.6.0 alpha2 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha3:*:*:*:node.js:*:* | 9.6.0 alpha3 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha4:*:*:*:node.js:*:* | 9.6.0 alpha4 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha5:*:*:*:node.js:*:* | 9.6.0 alpha5 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha6:*:*:*:node.js:*:* | 9.6.0 alpha6 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha7:*:*:*:node.js:*:* | 9.6.0 alpha7 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha8:*:*:*:node.js:*:* | 9.6.0 alpha8 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.35; 9.0.0 to before 9.6.0 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha1:*:*:*:node.js:*:* Versions 9.6.0 alpha1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha2:*:*:*:node.js:*:* Versions 9.6.0 alpha2 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha3:*:*:*:node.js:*:* Versions 9.6.0 alpha3 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha4:*:*:*:node.js:*:* Versions 9.6.0 alpha4 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha5:*:*:*:node.js:*:* Versions 9.6.0 alpha5 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha6:*:*:*:node.js:*:* Versions 9.6.0 alpha6 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha7:*:*:*:node.js:*:* Versions 9.6.0 alpha7 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha8:*:*:*:node.js:*:* Versions 9.6.0 alpha8 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 8.6.35
- Fix · GHSA-j7mm-f4rv-6q6q parse-server (npm) Fixed in 9.6.0-alpha.9 Advisory →
- Fix · GHSA-j7mm-f4rv-6q6q parse-server (npm) Fixed in 8.6.35 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-32098
- 2026-10-03 Alias added: GHSA-j7mm-f4rv-6q6q
References
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-32098 · CVE Program
- CVE-2026-32098 · NVD
- FIRST EPSS
- GHSA-j7mm-f4rv-6q6q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences