Read the docs
TI-2026-25204 Aliases CVE-2026-32712

Open Source Point of Sale has Stored XSS in Customer Name (Sales)

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Open Source Point of Sale is a web based point-of-sale application written in PHP using CodeIgniter framework. Prior to 3.4.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Daily Sales management table. The customer_name column is configured with escape: false in the bootstrap-table column configuration, causing customer names to be rendered as raw HTML. An attacker with customer management permissions can inject arbitrary JavaScript into a customer's first_name or last_name field, which executes in the browser of any user viewing the Daily Sales page. This vulnerability is fixed in 3.4.3.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00176 7th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed opensourcepos (opensourcepos): 3.4.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
opensourceposopensourceposbefore 3.4.33.4.3Patch availableCNA
  • opensourcepos Vendoropensourcepos Affected before 3.4.3 Fixed in 3.4.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opensourcepos:open_source_point_of_sale:*:*:*:*:*:*:*:*before 3.4.3Vulnerableopensourcepos
  • cpe:2.3:a:opensourcepos:open_source_point_of_sale:*:*:*:*:*:*:*:* Versions before 3.4.3 Vulnerable ·opensourcepos

Remediation

  • Fix · CNA opensourcepos (opensourcepos) Fixed in 3.4.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-32712

References

  • TI-2026-25347 Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality CVSS 3.1HIGH 8.8
  • TI-2025-41982 opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation CVSS 3.1HIGH 8.8
  • TI-2025-41728 opensourcepos has a Cross-site Scripting vulnerability CVSS 3.1HIGH 8.1
  • TI-2025-43027 An issue in OpenSourcePOS v3.4.1 allows attackers to execute arbitrary code via returning a crafted AJAX response. CVSS 3.1HIGH 7.4
  • TI-2025-41087 A Cross-site scripting (XSS) vulnerability in Create/Update Customer(s) in Open Source… CVSS 3.1HIGH 7.2
  • TI-2025-41086 A Cross-site scripting (XSS) vulnerability in Create/Update Item(s) Module in Open Source… CVSS 3.1HIGH 7.2
See all 18 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences