Parse Server session creation endpoint allows overwriting server-generated session fields
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-915.
Summary
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.17 and 8.6.42, an authenticated user can overwrite server-generated session fields (`sessionToken`, `expiresAt`, `createdWith`) when creating a session object via `POST /classes/_Session`. This allows bypassing the server's session expiration policy by setting an arbitrary far-future expiration date. It also allows setting a predictable session token value. Starting in version 9.6.0-alpha.17 and 8.6.42, the session creation endpoint filters out server-generated fields from user-supplied data, preventing them from being overwritten. As a workaround, add a `beforeSave` trigger on the `_Session` class to validate and reject or strip any user-supplied values for `sessionToken`, `expiresAt`, and `createdWith`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | 9.0.0 to before 9.6.0-alpha.17; before 8.6.42 | 9.6.0-alpha.17, 8.6.42 | Patch available | CNA |
| — | parse-server (npm) | 9.0.0 to before 9.6.0-alpha.17 | 9.6.0-alpha.17 | Patch available | GHSA-5v7g-9h8f-8pgg |
| — | parse-server (npm) | before 8.6.42 | 8.6.42 | Patch available | GHSA-5v7g-9h8f-8pgg |
- parse-server Vendorparse-community Affected 9.0.0 to before 9.6.0-alpha.17; before 8.6.42 Fixed in 9.6.0-alpha.17, 8.6.42 Patch available CNA
- parse-server (npm) Vendor— Affected 9.0.0 to before 9.6.0-alpha.17 Fixed in 9.6.0-alpha.17 Patch available GHSA-5v7g-9h8f-8pgg
- parse-server (npm) Vendor— Affected before 8.6.42 Fixed in 8.6.42 Patch available GHSA-5v7g-9h8f-8pgg
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 8.6.42; 9.0.0 to before 9.6.0 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha1:*:*:*:node.js:*:* | 9.6.0 alpha1 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha10:*:*:*:node.js:*:* | 9.6.0 alpha10 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha11:*:*:*:node.js:*:* | 9.6.0 alpha11 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha12:*:*:*:node.js:*:* | 9.6.0 alpha12 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha13:*:*:*:node.js:*:* | 9.6.0 alpha13 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha14:*:*:*:node.js:*:* | 9.6.0 alpha14 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha15:*:*:*:node.js:*:* | 9.6.0 alpha15 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha16:*:*:*:node.js:*:* | 9.6.0 alpha16 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha3:*:*:*:node.js:*:* | 9.6.0 alpha3 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.42; 9.0.0 to before 9.6.0 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha1:*:*:*:node.js:*:* Versions 9.6.0 alpha1 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha10:*:*:*:node.js:*:* Versions 9.6.0 alpha10 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha11:*:*:*:node.js:*:* Versions 9.6.0 alpha11 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha12:*:*:*:node.js:*:* Versions 9.6.0 alpha12 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha13:*:*:*:node.js:*:* Versions 9.6.0 alpha13 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha14:*:*:*:node.js:*:* Versions 9.6.0 alpha14 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha15:*:*:*:node.js:*:* Versions 9.6.0 alpha15 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha16:*:*:*:node.js:*:* Versions 9.6.0 alpha16 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha3:*:*:*:node.js:*:* Versions 9.6.0 alpha3 Vulnerable ·parse-community
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha4:*:*:*:node.js:*:* | 9.6.0 alpha4 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha5:*:*:*:node.js:*:* | 9.6.0 alpha5 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha6:*:*:*:node.js:*:* | 9.6.0 alpha6 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha7:*:*:*:node.js:*:* | 9.6.0 alpha7 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha8:*:*:*:node.js:*:* | 9.6.0 alpha8 | Vulnerable | parse-community |
| cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha9:*:*:*:node.js:*:* | 9.6.0 alpha9 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha4:*:*:*:node.js:*:* Versions 9.6.0 alpha4 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha5:*:*:*:node.js:*:* Versions 9.6.0 alpha5 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha6:*:*:*:node.js:*:* Versions 9.6.0 alpha6 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha7:*:*:*:node.js:*:* Versions 9.6.0 alpha7 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha8:*:*:*:node.js:*:* Versions 9.6.0 alpha8 Vulnerable ·parse-community
- cpe:2.3:a:parseplatform:parse-server:9.6.0:alpha9:*:*:*:node.js:*:* Versions 9.6.0 alpha9 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 9.6.0-alpha.17, 8.6.42
- Fix · GHSA-5v7g-9h8f-8pgg parse-server (npm) Fixed in 9.6.0-alpha.17 Advisory →
- Fix · GHSA-5v7g-9h8f-8pgg parse-server (npm) Fixed in 8.6.42 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-32742
- 2026-10-03 Alias added: GHSA-5v7g-9h8f-8pgg
References
Advisory 2
More parse-community Parse-server vulnerabilities
- TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
Sources
- CVE-2026-32742 · CVE Program
- CVE-2026-32742 · NVD
- FIRST EPSS
- GHSA-5v7g-9h8f-8pgg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences