Read the docs
TI-2026-25618 Aliases CVE-2026-33193

Docmost vulnerable to stored XSS via MIME type spoofing

Priority LOW 20CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Docmost is open-source collaborative wiki and documentation software. Versions prior to 0.70.0 are vulnerable to a stored cross-site scripting (XSS) attack due to improper handling of MIME type spoofing (GHSL-2026-052). An attacker could exploit this flaw to inject malicious scripts, potentially compromising the security of users and data. Version 0.70.0 contains a patch.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00187 8th percentileScored 2026-11-07
Fix Fixed docmost (docmost): 0.70.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
docmostdocmostbefore 0.70.00.70.0Patch availableCNA
  • docmost Vendordocmost Affected before 0.70.0 Fixed in 0.70.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:docmost:docmost:*:*:*:*:*:*:*:*before 0.70.0Vulnerabledocmost
  • cpe:2.3:a:docmost:docmost:*:*:*:*:*:*:*:* Versions before 0.70.0 Vulnerable ·docmost

Remediation

  • Fix · CNA docmost (docmost) Fixed in 0.70.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-33193

References

  • TI-2026-17859 Docmost affected by an Arbitrary File Write via Zip Import Feature (ZipSlip) CVSS 3.1CRITICAL 9.8
  • TI-2026-19373 Docmost Affected by Stored XSS in Public Share Page CVSS 3.1HIGH 7.3
  • TI-2025-35043 Cross Site Scripting vulnerability in docmost v.0.21.0 and before allows an attacker to execute arbitrary code CVSS 3.1MEDIUM 6.1
  • TI-2026-19029 Docmost is vulnerable to stored Cross-Site Scripting (XSS) through Mermaid rendering CVSS 4.0MEDIUM 6.3
  • TI-2026-26508 Docmost has cross-page attachment overwrite via flawed attachmentId overwrite validation CVSS 3.1MEDIUM 5.4
  • TI-2026-26507 Docmost page content has stored XSS via unsanitized attachment URLs CVSS 3.1MEDIUM 5.4
See all 8 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences