Pi-hole Web Interface has a Command Injection Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level ad and internet tracker blocking application. Versions prior to 6.0 have a critical OS Command Injection vulnerability in the savesettings.php file. The application takes the user-controlled $_POST['webtheme'] parameter and concatenates it directly into a system command executed via PHP's exec() function. Since the input is neither sanitized nor validated before being passed to the shell, an attacker can append arbitrary system commands to the intended pihole command. Furthermore, because the command is executed with sudo privileges, the injected commands will run with elevated (likely root) privileges. Version 6.0 patches the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA web (pi-hole) Fixed in 6.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-33765
References
More Pi-hole Web Interface vulnerabilities
- TI-2023-09443 Improper session handling of "Remember me for 7 days" functionality CVSS 3.1HIGH 8.8
- TI-2025-36756 Pi-hole Admin Interface vulnerable to HTTP response header injection via CRLF injection CVSS 3.1HIGH 8.2
- TI-2026-25803 Pi-hole has a Stored HTML attribute injection CVSS 3.1MEDIUM 6.1
- TI-2026-25801 Pi-hole has a Stored XSS / HTML injection in the Network page/Dashboard CVSS 3.1MEDIUM 6.1
- TI-2026-25800 Pi-hole has a Reflected XSS / HTML injection in taillog.js CVSS 3.1MEDIUM 6.1
- TI-2025-33477 Pi-hole Admin Interface vulnerable to cross-site scripting via malformed URL path on 404 error page CVSS 4.0MEDIUM 5.1
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences