Read the docs
TI-2026-26362 Aliases CVE-2026-34036GHSA-2mfj-r695-5h9r

Dolibarr Core Discloses Sensitive Data via Authenticated Local File Inclusion in selectobject.php

Priority MEDIUM 62CWE-98Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-98.

Summary

Dolibarr is an enterprise resource planning (ERP) and customer relationship management (CRM) software package. In versions 22.0.4 and prior, there is a Local File Inclusion (LFI) vulnerability in the core AJAX endpoint /core/ajax/selectobject.php. By manipulating the objectdesc parameter and exploiting a fail-open logic flaw in the core access control function restrictedArea(), an authenticated user with no specific privileges can read the contents of arbitrary non-PHP files on the server (such as .env, .htaccess, configuration backups, or logs…). At time of publication, there are no publicly available patches.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01464 73rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed dolibarr/dolibarr (Packagist): 23.0.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Dolibarrdolibarrup to 22.0.4—No fix listedCNA
—dolibarr/dolibarr (Packagist)before 23.0.023.0.0Patch availableGHSA-2mfj-r695-5h9r
  • dolibarr VendorDolibarr Affected up to 22.0.4 Fixed in — No fix listed CNA
  • dolibarr/dolibarr (Packagist) Vendor— Affected before 23.0.0 Fixed in 23.0.0 Patch available GHSA-2mfj-r695-5h9r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:dolibarr:dolibarr_erp\/crm:*:*:*:*:*:*:*:*up to 22.0.4VulnerableDolibarr
  • cpe:2.3:a:dolibarr:dolibarr_erp\/crm:*:*:*:*:*:*:*:* Versions up to 22.0.4 Vulnerable ·Dolibarr

Remediation

  • Fix · GHSA-2mfj-r695-5h9r dolibarr/dolibarr (Packagist) Fixed in 23.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-34036
  2. 2026-10-03 Alias added: GHSA-2mfj-r695-5h9r

References

  • TI-2022-21049 Dolibarr Open Source ERP & CRM for Business before v14.0.1 allows attackers to escalate privileges via a crafted API. CVSS 3.1CRITICAL 9.8
  • TI-2022-03742 SQL Injection in dolibarr/dolibarr CVSS 3.1CRITICAL 9.8
  • TI-2023-14191 Dolibarr before 17.0.1 allows remote code execution by an authenticated user via an… CVSS 3.1HIGH 8.8
  • TI-2018-15582 Dolibarr ERP CRM 7.0.3 Remote Code Execution via install/step1.php CVSS 4.0CRITICAL 9.3
  • TI-2019-15505 Dolibarr ERP/CRM 10.0.1 SQL Injection via elemid CVSS 4.0HIGH 8.8
  • TI-2026-18933 Dolibarr: OS Command Injection (RCE) via MAIN_ODT_AS_PDF configuration CVSS 4.0CRITICAL 9.4
See all 110 →

Sources