Read the docs
TI-2026-26519 Aliases CVE-2026-34224GHSA-w73w-g5xw-rwhf

Parse Server: MFA single-use token bypass via concurrent authData login requests

Priority LOW 11CWE-367Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
High
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.64 and 9.7.0-alpha.8, an attacker who possesses a valid authentication provider token and a single MFA recovery code or SMS one-time password can create multiple authenticated sessions by sending concurrent login requests via the authData login endpoint. This defeats the single-use guarantee of MFA recovery codes and SMS one-time passwords, allowing session persistence even after the legitimate user revokes detected sessions. This issue has been patched in versions 8.6.64 and 9.7.0-alpha.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00317 24th percentileScored 2026-11-07
Fix Fixed parse-server (parse-community): 8.6.64, 9.7.0-alpha.8parse-server (npm): 9.7.0-alpha.8, 8.6.64

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
parse-communityparse-serverbefore 8.6.64; 9.0.0 to before 9.7.0-alpha.88.6.64, 9.7.0-alpha.8Patch availableCNA
—parse-server (npm)9.0.0 to before 9.7.0-alpha.89.7.0-alpha.8Patch availableGHSA-w73w-g5xw-rwhf
—parse-server (npm)before 8.6.648.6.64Patch availableGHSA-w73w-g5xw-rwhf
  • parse-server Vendorparse-community Affected before 8.6.64; 9.0.0 to before 9.7.0-alpha.8 Fixed in 8.6.64, 9.7.0-alpha.8 Patch available CNA
  • parse-server (npm) Vendor— Affected 9.0.0 to before 9.7.0-alpha.8 Fixed in 9.7.0-alpha.8 Patch available GHSA-w73w-g5xw-rwhf
  • parse-server (npm) Vendor— Affected before 8.6.64 Fixed in 8.6.64 Patch available GHSA-w73w-g5xw-rwhf

CPE configurations NVD · 8

CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*before 8.6.64; 9.0.0 to before 9.7.0Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha1:*:*:*:node.js:*:*9.7.0 alpha1Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha2:*:*:*:node.js:*:*9.7.0 alpha2Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha3:*:*:*:node.js:*:*9.7.0 alpha3Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha4:*:*:*:node.js:*:*9.7.0 alpha4Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha5:*:*:*:node.js:*:*9.7.0 alpha5Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha6:*:*:*:node.js:*:*9.7.0 alpha6Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha7:*:*:*:node.js:*:*9.7.0 alpha7Vulnerableparse-community
  • cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.64; 9.0.0 to before 9.7.0 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha1:*:*:*:node.js:*:* Versions 9.7.0 alpha1 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha2:*:*:*:node.js:*:* Versions 9.7.0 alpha2 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha3:*:*:*:node.js:*:* Versions 9.7.0 alpha3 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha4:*:*:*:node.js:*:* Versions 9.7.0 alpha4 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha5:*:*:*:node.js:*:* Versions 9.7.0 alpha5 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha6:*:*:*:node.js:*:* Versions 9.7.0 alpha6 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha7:*:*:*:node.js:*:* Versions 9.7.0 alpha7 Vulnerable ·parse-community

Remediation

  • Fix · CNA parse-server (parse-community) Fixed in 8.6.64, 9.7.0-alpha.8
  • Fix · GHSA-w73w-g5xw-rwhf parse-server (npm) Fixed in 9.7.0-alpha.8 Advisory →
  • Fix · GHSA-w73w-g5xw-rwhf parse-server (npm) Fixed in 8.6.64 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-34224
  2. 2026-10-03 Alias added: GHSA-w73w-g5xw-rwhf

References

  • TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
  • TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
  • TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
  • TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
  • TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
See all 101 →

Sources