Read the docs
TI-2026-26659 Aliases CVE-2026-34373GHSA-q3p6-g7c4-829c

Parse Server: GraphQL API endpoint ignores CORS origin restriction

Priority LOW 23CWE-346Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
None · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-346.

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.66 and 9.7.0-alpha.10, the GraphQL API endpoint does not respect the allowOrigin server option and unconditionally allows cross-origin requests from any website. This bypasses origin restrictions that operators configure to control which websites can interact with the Parse Server API. The REST API correctly enforces the configured allowOrigin restriction. This issue has been patched in versions 8.6.66 and 9.7.0-alpha.10.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00205 10th percentileScored 2026-11-07
Fix Fixed parse-server (parse-community): 8.6.66, 9.7.0-alpha.10parse-server (npm): 9.7.0-alpha.10, 8.6.66

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
parse-communityparse-serverbefore 8.6.66; 9.0.0 to before 9.7.0-alpha.108.6.66, 9.7.0-alpha.10Patch availableCNA
—parse-server (npm)9.0.0 to before 9.7.0-alpha.109.7.0-alpha.10Patch availableGHSA-q3p6-g7c4-829c
—parse-server (npm)3.5.0 to before 8.6.668.6.66Patch availableGHSA-q3p6-g7c4-829c
  • parse-server Vendorparse-community Affected before 8.6.66; 9.0.0 to before 9.7.0-alpha.10 Fixed in 8.6.66, 9.7.0-alpha.10 Patch available CNA
  • parse-server (npm) Vendor— Affected 9.0.0 to before 9.7.0-alpha.10 Fixed in 9.7.0-alpha.10 Patch available GHSA-q3p6-g7c4-829c
  • parse-server (npm) Vendor— Affected 3.5.0 to before 8.6.66 Fixed in 8.6.66 Patch available GHSA-q3p6-g7c4-829c

CPE configurations NVD · 10

CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*3.5.0 to before 8.6.66; 9.0.0 to before 9.7.0Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha1:*:*:*:node.js:*:*9.7.0 alpha1Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha2:*:*:*:node.js:*:*9.7.0 alpha2Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha3:*:*:*:node.js:*:*9.7.0 alpha3Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha4:*:*:*:node.js:*:*9.7.0 alpha4Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha5:*:*:*:node.js:*:*9.7.0 alpha5Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha6:*:*:*:node.js:*:*9.7.0 alpha6Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha7:*:*:*:node.js:*:*9.7.0 alpha7Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha8:*:*:*:node.js:*:*9.7.0 alpha8Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha9:*:*:*:node.js:*:*9.7.0 alpha9Vulnerableparse-community
  • cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions 3.5.0 to before 8.6.66; 9.0.0 to before 9.7.0 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha1:*:*:*:node.js:*:* Versions 9.7.0 alpha1 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha2:*:*:*:node.js:*:* Versions 9.7.0 alpha2 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha3:*:*:*:node.js:*:* Versions 9.7.0 alpha3 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha4:*:*:*:node.js:*:* Versions 9.7.0 alpha4 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha5:*:*:*:node.js:*:* Versions 9.7.0 alpha5 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha6:*:*:*:node.js:*:* Versions 9.7.0 alpha6 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha7:*:*:*:node.js:*:* Versions 9.7.0 alpha7 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha8:*:*:*:node.js:*:* Versions 9.7.0 alpha8 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.7.0:alpha9:*:*:*:node.js:*:* Versions 9.7.0 alpha9 Vulnerable ·parse-community

Remediation

  • Fix · CNA parse-server (parse-community) Fixed in 8.6.66, 9.7.0-alpha.10
  • Fix · GHSA-q3p6-g7c4-829c parse-server (npm) Fixed in 9.7.0-alpha.10 Advisory →
  • Fix · GHSA-q3p6-g7c4-829c parse-server (npm) Fixed in 8.6.66 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-34373
  2. 2026-10-03 Alias added: GHSA-q3p6-g7c4-829c

References

  • TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
  • TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
  • TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
  • TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
  • TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
See all 101 →

Sources