Adobe Experience Manager Forms JEE | Cross-site Scripting (Stored XSS) (CWE-79)
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Adobe Experience Manager Forms JEE versions LTS SP1, 6.5.24.0 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a high-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim's browser when they browse to the page containing the vulnerable field. Scope is changed.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Adobe Experience Manager 6.5 LTS | up to SP1 | SP2 | Patch available | CNA |
| Adobe | Adobe Experience Manager 6.5 | up to 6.5.24 | 6.5.25 | Patch available | CNA |
- Adobe Experience Manager 6.5 LTS VendorAdobe Affected up to SP1 Fixed in SP2 Patch available CNA
- Adobe Experience Manager 6.5 VendorAdobe Affected up to 6.5.24 Fixed in 6.5.25 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:experience_manager:*:*:*:*:-:*:*:* | up to 6.5.24.0 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:experience_manager:6.5:-:*:*:lts:*:*:* | 6.5 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:experience_manager:6.5:sp1:*:*:lts:*:*:* | 6.5 sp1 | Vulnerable | Adobe |
| cpe:2.3:o:apple:iphone_os:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Apple |
| cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Apple |
| cpe:2.3:o:google:android:-:*:*:*:*:*:*:* | not specified by NVD | Running on | |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:adobe:experience_manager:*:*:*:*:-:*:*:* Versions up to 6.5.24.0 Vulnerable ·Adobe
- cpe:2.3:a:adobe:experience_manager:6.5:-:*:*:lts:*:*:* Versions 6.5 Vulnerable ·Adobe
- cpe:2.3:a:adobe:experience_manager:6.5:sp1:*:*:lts:*:*:* Versions 6.5 sp1 Vulnerable ·Adobe
- cpe:2.3:o:apple:iphone_os:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Apple
- cpe:2.3:o:apple:macos:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Apple
- cpe:2.3:o:google:android:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Google
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Adobe Experience Manager 6.5 LTS (Adobe) Fixed in SP2
- Fix · CNA Adobe Experience Manager 6.5 (Adobe) Fixed in 6.5.25
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Adobe Experience Manager 6.5, Adobe Experience Manager 6.5 LTS — helpx.adobe.com/security/products/aem-forms/apsb26-57.html
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2026-26935 Adobe Experience Manager Forms JEE | Cross-site Scripting (Stored XSS) (CWE-79)Priority MEDIUM 42
- TI-2026-26937 Adobe Experience Manager Forms JEE | Cross-site Scripting (Reflected XSS) (CWE-79)Priority LOW 37
Timeline
- 2026-10-02 Threatist record created from CVE-2026-34694
- 2026-10-03 Alias added: GHSA-rj84-7c55-q3v8
References
More Adobe Experience Manager vulnerabilities
- TI-2025-31549 Adobe Experience Manager (MS) | Deserialization of Untrusted Data (CWE-502) CVSS 3.1CRITICAL 9.8
- TI-2018-03574 Server-side request forgery in Adobe Experience Manager AEM 6.4 and earlier CVSS 3.0HIGH 7.5
- TI-2016-00865 Dispatcher before 4.1.5 in Adobe Experience Manager 5.6.1, 6.0.0, and 6.1.0 does not… CVSS 3.0HIGH 7.5
- TI-2016-00864 The Servlets Post component 2.3.6 in Apache Sling, as used in Adobe Experience Manager… CVSS 3.0HIGH 7.5
- TI-2019-05642 Adobe Experience Manager versions 6.5, and 6.4 have an authentication bypass… CVSS 3.0CRITICAL 9.8
- TI-2019-05759 XML external entity injection in Adobe Experience Manager CVSS 3.1HIGH 7.5
Sources
- CVE-2026-34694 · CVE Program
- CVE-2026-34694 · NVD
- FIRST EPSS
- GHSA-rj84-7c55-q3v8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences