Zammad is miissing authorization in AI assistance controller for context data used in text tools
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
Zammad is a web based open source helpdesk/customer support system. Prior to 7.0.1, he REST endpoint POST /api/v1/ai_assistance/text_tools/:id contains an authorization failure. Context data (e.g., a group or organization) supplied to be used in the AI prompt were not checked if they are accessible for the current user. This leads to having data present in the AI prompt that were not authorized before being used. A user needs to have ticket.agent permission to be able to use the provided context data. This vulnerability is fixed in 7.0.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Zammad GmbH | zammad | 7.0.0 to before 7.0.1 | 7.0.1 | Patch available | CNA |
- zammad VendorZammad GmbH Affected 7.0.0 to before 7.0.1 Fixed in 7.0.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zammad:zammad:7.0.0:*:*:*:*:*:*:* | 7.0.0 | Vulnerable | Zammad GmbH |
- cpe:2.3:a:zammad:zammad:7.0.0:*:*:*:*:*:*:* Versions 7.0.0 Vulnerable ·Zammad GmbH
Remediation
- Fix · CNA zammad (zammad) Fixed in 7.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-34837
References
More Zammad GmbH Zammad vulnerabilities
- TI-2026-65406 Local privilege escalation in Zammad v1.5.0 to v7.2.2 installed via DEB or RPM package KEVCVSS 4.0CRITICAL 9.4
- TI-2026-65405 Undisclosed RCE in Zammad v6.3 and higher KEVCVSS 4.0CRITICAL 9.4
- TI-2024-22252 An issue was discovered in Zammad before 6.3.0. CVSS 3.1CRITICAL 9.1
- TI-2022-23785 A vulnerability in Zammad v5.3.0 allows attackers to execute arbitrary code or escalate… CVSS 3.1CRITICAL 9.8
- TI-2021-18599 An issue was discovered in Zammad before 4.1.1. CVSS 3.1CRITICAL 9.8
- TI-2021-18603 An issue was discovered in Zammad before 4.1.1. CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences