OS command injection in openNDS
Key facts
- Attack vector
- Adjacent network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
In openNDS before 11.0.0, the client_params.sh script, invoked by the openNDS daemon to serve the authenticated client status page, is vulnerable to OS command injection through crafted HTTP GET query parameter keys. An authenticated captive portal user can inject arbitrary shell commands by embedding semicolons in a URL query parameter name.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA openNDS (openNDS) Fixed in 11.0.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
openNDS 11.0.0
4 records Highest priority Priority MEDIUM 2 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2026-28214 OS command injection in openNDSPriority MEDIUM 43
- TI-2026-28215 Heap-based buffer overflow in openNDSPriority LOW 33
- TI-2026-28213 Memory leak in openNDSPriority LOW 24
Timeline
- 2026-10-02 Threatist record created from CVE-2026-38822
- 2026-10-03 Alias added: GHSA-2h6c-w4mg-27v5
More openNDS vulnerabilities
- TI-2023-19721 An issue was discovered in OpenNDS before 10.1.3. CVSS 3.1CRITICAL 9.8
- TI-2023-21723 An issue was discovered in the captive portal in OpenNDS before version 10.1.3. CVSS 3.1CRITICAL 9.8
- TI-2023-19715 An issue was discovered in OpenNDS before 10.1.3. CVSS 3.1CRITICAL 9.8
- TI-2023-19714 An issue was discovered in OpenNDS Captive Portal before version 10.1.2. CVSS 3.1CRITICAL 9.8
- TI-2023-19717 An issue was discovered in OpenNDS before 10.1.3. CVSS 3.1CRITICAL 9.8
- TI-2023-19716 An issue was discovered in OpenNDS before 10.1.3. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-38822 · CVE Program
- CVE-2026-38822 · NVD
- FIRST EPSS
- GHSA-2h6c-w4mg-27v5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences