Open Source Point of Sale has Stored XSS in Stock Location (Configuration)
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Open Source Point of Sale is a web based point-of-sale application written in PHP using CodeIgniter framework. Prior to 3.4.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Stock Locations configuration feature. The application fails to properly sanitize user input supplied through the stock_location parameter, allowing attackers to inject malicious JavaScript code that is stored in the database and executed when rendered in the Employees interface. This vulnerability is fixed in 3.4.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| opensourcepos | opensourcepos | before 3.4.3 | 3.4.3 | Patch available | CNA |
- opensourcepos Vendoropensourcepos Affected before 3.4.3 Fixed in 3.4.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensourcepos:open_source_point_of_sale:*:*:*:*:*:*:*:* | before 3.4.3 | Vulnerable | opensourcepos |
- cpe:2.3:a:opensourcepos:open_source_point_of_sale:*:*:*:*:*:*:*:* Versions before 3.4.3 Vulnerable ·opensourcepos
Remediation
- Fix · CNA opensourcepos (opensourcepos) Fixed in 3.4.3
Timeline
- 2026-10-02 Threatist record created from CVE-2026-39380
References
More opensourcepos Open Source Point Of Sale vulnerabilities
- TI-2026-25347 Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality CVSS 3.1HIGH 8.8
- TI-2025-41982 opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation CVSS 3.1HIGH 8.8
- TI-2025-41728 opensourcepos has a Cross-site Scripting vulnerability CVSS 3.1HIGH 8.1
- TI-2025-43027 An issue in OpenSourcePOS v3.4.1 allows attackers to execute arbitrary code via returning a crafted AJAX response. CVSS 3.1HIGH 7.4
- TI-2025-41087 A Cross-site scripting (XSS) vulnerability in Create/Update Customer(s) in Open Source… CVSS 3.1HIGH 7.2
- TI-2025-41086 A Cross-site scripting (XSS) vulnerability in Create/Update Item(s) Module in Open Source… CVSS 3.1HIGH 7.2
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences