Read the docs
TI-2026-28366 Aliases CVE-2026-39381GHSA-g4v2-qx3q-4p64

Parse Server's Endpoint `/sessions/me` bypasses `_Session` `protectedFields`

Priority LOW 23CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.8.0-alpha.7 and 8.6.75, the GET /sessions/me endpoint returns _Session fields that the server operator explicitly configured as protected via the protectedFields server option. Any authenticated user can retrieve their own session's protected fields with a single request. The equivalent GET /sessions and GET /sessions/:objectId endpoints correctly strip protected fields. This vulnerability is fixed in 9.8.0-alpha.7 and 8.6.75.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.002 9th percentileScored 2026-11-07
Fix Fixed parse-server (parse-community): 9.8.0-alpha.7, 8.6.75parse-server (npm): 9.8.0-alpha.7, 8.6.75

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
parse-communityparse-server9.0.0 to before 9.8.0-alpha.7; 7.0.0 to before 8.6.759.8.0-alpha.7, 8.6.75Patch availableCNA
—parse-server (npm)9.0.0 to before 9.8.0-alpha.79.8.0-alpha.7Patch availableGHSA-g4v2-qx3q-4p64
—parse-server (npm)7.0.0 to before 8.6.758.6.75Patch availableGHSA-g4v2-qx3q-4p64
  • parse-server Vendorparse-community Affected 9.0.0 to before 9.8.0-alpha.7; 7.0.0 to before 8.6.75 Fixed in 9.8.0-alpha.7, 8.6.75 Patch available CNA
  • parse-server (npm) Vendor— Affected 9.0.0 to before 9.8.0-alpha.7 Fixed in 9.8.0-alpha.7 Patch available GHSA-g4v2-qx3q-4p64
  • parse-server (npm) Vendor— Affected 7.0.0 to before 8.6.75 Fixed in 8.6.75 Patch available GHSA-g4v2-qx3q-4p64

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*before 8.6.75; 9.0.0 to before 9.8.0Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha1:*:*:*:node.js:*:*9.8.0 alpha1Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha2:*:*:*:node.js:*:*9.8.0 alpha2Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha3:*:*:*:node.js:*:*9.8.0 alpha3Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha4:*:*:*:node.js:*:*9.8.0 alpha4Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha5:*:*:*:node.js:*:*9.8.0 alpha5Vulnerableparse-community
cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha6:*:*:*:node.js:*:*9.8.0 alpha6Vulnerableparse-community
  • cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 8.6.75; 9.0.0 to before 9.8.0 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha1:*:*:*:node.js:*:* Versions 9.8.0 alpha1 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha2:*:*:*:node.js:*:* Versions 9.8.0 alpha2 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha3:*:*:*:node.js:*:* Versions 9.8.0 alpha3 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha4:*:*:*:node.js:*:* Versions 9.8.0 alpha4 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha5:*:*:*:node.js:*:* Versions 9.8.0 alpha5 Vulnerable ·parse-community
  • cpe:2.3:a:parseplatform:parse-server:9.8.0:alpha6:*:*:*:node.js:*:* Versions 9.8.0 alpha6 Vulnerable ·parse-community

Remediation

  • Fix · CNA parse-server (parse-community) Fixed in 9.8.0-alpha.7, 8.6.75
  • Fix · GHSA-g4v2-qx3q-4p64 parse-server (npm) Fixed in 9.8.0-alpha.7 Advisory →
  • Fix · GHSA-g4v2-qx3q-4p64 parse-server (npm) Fixed in 8.6.75 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-39381
  2. 2026-10-03 Alias added: GHSA-g4v2-qx3q-4p64

References

  • TI-2022-08574 Command Injection in Parse server CVSS 3.1CRITICAL 10.0
  • TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
  • TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
  • TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
  • TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
  • TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
See all 101 →

Sources