CI4MS has a Hidden Items Authorization Bypass in Fileeditor Allows Reading Secrets and Writing Protected Files
Priority HIGH 67CWE-285Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to 0.31.4.0, This vulnerability is fixed in 0.31.4.0.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0049 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ci4ms (ci4-cms-erp): 0.31.4.0ci4-cms-erp/ci4ms (Packagist): 0.31.4.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ci4-cms-erp | ci4ms | before 0.31.4.0 | 0.31.4.0 | Patch available | CNA |
| — | ci4-cms-erp/ci4ms (Packagist) | before 0.31.4.0 | 0.31.4.0 | Patch available | GHSA-9rxp-f27p-wv3h |
- ci4ms Vendorci4-cms-erp Affected before 0.31.4.0 Fixed in 0.31.4.0 Patch available CNA
- ci4-cms-erp/ci4ms (Packagist) Vendor— Affected before 0.31.4.0 Fixed in 0.31.4.0 Patch available GHSA-9rxp-f27p-wv3h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ci4-cms-erp:ci4ms:*:*:*:*:*:*:*:* | before 0.31.4.0 | Vulnerable | ci4-cms-erp |
- cpe:2.3:a:ci4-cms-erp:ci4ms:*:*:*:*:*:*:*:* Versions before 0.31.4.0 Vulnerable ·ci4-cms-erp
Remediation
- Fix · CNA ci4ms (ci4-cms-erp) Fixed in 0.31.4.0
- Fix · GHSA-9rxp-f27p-wv3h ci4-cms-erp/ci4ms (Packagist) Fixed in 0.31.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-39389
- 2026-10-03 Alias added: GHSA-9rxp-f27p-wv3h
References
More ci4-cms-erp Ci4ms vulnerabilities
- TI-2026-26819 Improper access control in ci4-cms-erp ci4ms CVSS 3.1HIGH 8.8
- TI-2026-28379 CI4MS has an .env CRLF Injection via Unvalidated `host` Parameter in Install Controller CVSS 3.1CRITICAL 9.8
- TI-2026-27211 Cross-site scripting in ci4-cms-erp ci4ms CVSS 4.0CRITICAL 9.4
- TI-2026-26820 Cross-site scripting in ci4-cms-erp ci4ms CVSS 3.1CRITICAL 10.0
- TI-2026-26818 CI4MS: Blogs Categories Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM XSS CVSS 3.1CRITICAL 10.0
- TI-2026-27238 Cross-site scripting in ci4-cms-erp ci4ms CVSS 3.1CRITICAL 9.0
Sources
- CVE-2026-39389 · CVE Program
- CVE-2026-39389 · NVD
- FIRST EPSS
- GHSA-9rxp-f27p-wv3h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences