Apache APISIX: Identity Injection via forward-auth Plugin Missing Header Cleanup
Priority LOW 33CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Improper Input Validation vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to spoof identity headers. This issue affects Apache APISIX: from 2.12.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00676 52nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-39998
- 2026-10-03 Alias added: GHSA-86hq-f9pp-3cr9
References
More Apache Apisix vulnerabilities
- TI-2022-08057 apisix/batch-requests plugin allows overwriting the X-REAL-IP header KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2020-10921 In Apache APISIX, the user enabled the Admin API and deleted the Admin API access IP… CVSS 3.1MEDIUM 6.5
- TI-2026-24457 Apache APISIX: forward auth plugin allows header injection CVSS 3.1CRITICAL 9.1
- TI-2022-09331 Apache APISIX: the body_schema check in request-validation plugin can be bypassed CVSS 3.1CRITICAL 9.8
- TI-2021-19447 Path traversal in request_uri variable CVSS 3.1HIGH 7.5
Sources
- CVE-2026-39998 · CVE Program
- CVE-2026-39998 · NVD
- FIRST EPSS
- GHSA-86hq-f9pp-3cr9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences