Resource allocation without limits in varnish-software Varnish Enterprise
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-770.
Summary
Varnish Enterprise before 6.0.16r12 allows a "workspace overflow" denial of service (daemon panic) for shared VCL. The headerplus.write_req0() function from vmod_headerplus updates the underlying req0, which is normally the original read-only request from which req is derived (readable and writable from VCL). This is useful in the active VCL, after amending req, to prepare a refined req0 before switching to a different VCL with the return (vcl(<label>)) action. This is for example how the Varnish Controller operates shared VCL deployments. If the amended req contained too many header fields for req0, this would have resulted in a workspace overflow that would in turn trigger a panic and crash the Varnish Enterprise server. This could be used as a Denial of Service attack vector by malicious clients.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| varnish-software | Varnish Enterprise | 6.0.9r5 to before 6.0.16r12 | 6.0.16r12 | Patch available | CNA |
- Varnish Enterprise Vendorvarnish-software Affected 6.0.9r5 to before 6.0.16r12 Fixed in 6.0.16r12 Patch available CNA
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:varnish-software:varnish_enterprise:*:*:*:*:*:*:*:* | up to 6.0.15 | Vulnerable | varnish-software |
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r1:*:*:*:*:*:* | 6.0.16 r1 | Vulnerable | varnish-software |
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r10:*:*:*:*:*:* | 6.0.16 r10 | Vulnerable | varnish-software |
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r11:*:*:*:*:*:* | 6.0.16 r11 | Vulnerable | varnish-software |
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r2:*:*:*:*:*:* | 6.0.16 r2 | Vulnerable | varnish-software |
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r3:*:*:*:*:*:* | 6.0.16 r3 | Vulnerable | varnish-software |
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r4:*:*:*:*:*:* | 6.0.16 r4 | Vulnerable | varnish-software |
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r5:*:*:*:*:*:* | 6.0.16 r5 | Vulnerable | varnish-software |
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r6:*:*:*:*:*:* | 6.0.16 r6 | Vulnerable | varnish-software |
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r7:*:*:*:*:*:* | 6.0.16 r7 | Vulnerable | varnish-software |
- cpe:2.3:a:varnish-software:varnish_enterprise:*:*:*:*:*:*:*:* Versions up to 6.0.15 Vulnerable ·varnish-software
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r1:*:*:*:*:*:* Versions 6.0.16 r1 Vulnerable ·varnish-software
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r10:*:*:*:*:*:* Versions 6.0.16 r10 Vulnerable ·varnish-software
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r11:*:*:*:*:*:* Versions 6.0.16 r11 Vulnerable ·varnish-software
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r2:*:*:*:*:*:* Versions 6.0.16 r2 Vulnerable ·varnish-software
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r3:*:*:*:*:*:* Versions 6.0.16 r3 Vulnerable ·varnish-software
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r4:*:*:*:*:*:* Versions 6.0.16 r4 Vulnerable ·varnish-software
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r5:*:*:*:*:*:* Versions 6.0.16 r5 Vulnerable ·varnish-software
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r6:*:*:*:*:*:* Versions 6.0.16 r6 Vulnerable ·varnish-software
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r7:*:*:*:*:*:* Versions 6.0.16 r7 Vulnerable ·varnish-software
Show 2 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r8:*:*:*:*:*:* | 6.0.16 r8 | Vulnerable | varnish-software |
| cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r9:*:*:*:*:*:* | 6.0.16 r9 | Vulnerable | varnish-software |
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r8:*:*:*:*:*:* Versions 6.0.16 r8 Vulnerable ·varnish-software
- cpe:2.3:a:varnish-software:varnish_enterprise:6.0.16:r9:*:*:*:*:*:* Versions 6.0.16 r9 Vulnerable ·varnish-software
Remediation
- Fix · CNA Varnish Enterprise (varnish-software) Fixed in 6.0.16r12
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-40395
- 2026-10-03 Alias added: GHSA-59jh-85v4-gxrf
References
More varnish-software Varnish Enterprise vulnerabilities
- TI-2026-26733 Varnish Cache before 8.0.1 and Varnish Enterprise before 6.0.16r12, in certain unchecked… CVSS 3.1CRITICAL 9.8
- TI-2023-21726 libvmod-digest before 1.0.3, as used in Varnish Enterprise 6.0.x before 6.0.11r5, has an… CVSS 3.1MEDIUM 6.5
- TI-2025-21653 Out-of-bounds read in varnish-software Varnish Enterprise CVSS 3.1HIGH 7.5
- TI-2026-29162 Varnish Cache 9 before 9.0.1 and Varnish Enterprise before 6.0.16r11 allows a "workspace… CVSS 3.1HIGH 7.5
- TI-2025-21652 Varnish Cache before 7.6.2 and Varnish Enterprise before 6.0.13r10 allow client-side desync via HTTP/1 requests. CVSS 3.1MEDIUM 5.4
Sources
- CVE-2026-40395 · CVE Program
- CVE-2026-40395 · NVD
- FIRST EPSS
- GHSA-59jh-85v4-gxrf · GitHub Advisory Database · CC BY 4.0
- CVE-2026-40395 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences