Read the docs

varnish-software

Records18All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical2CVSS 9.0–10.0
CVSS high10CVSS 7.0–8.9

Exploited now

varnish-software records in CISA KEV

No varnish-software vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

18 records

Priority HIGH 72

A mismatch caused by client-triggered server-sent stream resets between HTTP/2 specifications and the internal architectures of some HTTP/2 implementations may result in excessive server resource consumption leading to d…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.03637 Published 2025-08-13 Fixed in 15-SP5, 15 SP5 +1 CWE-404
Priority MEDIUM 41

Varnish Cache before 8.0.1 and Varnish Enterprise before 6.0.16r12, in certain unchecked req.url scenarios, mishandle URLs with a path of / for HTTP/1.1, potentially leading to cache poisoning or authentication bypass.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0021 Published 2026-03-27 Partial fix · 6.0.17 LTS, 8.0.1 CWE-180
Priority LOW 36

libvmod-digest before 1.0.3, as used in Varnish Enterprise 6.0.x before 6.0.11r5, has an out-of-bounds memory access during base64 decoding, leading to both authentication bypass and information disclosure; however, the…

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.00595 Published 2023-08-23 No fix listed CWE-119
Priority LOW 33

Varnish Enterprise before 6.0.13r13 allows remote attackers to obtain sensitive information via an out-of-bounds read for range requests on ephemeral MSE4 stevedore objects.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00351 Published 2025-03-21 Fixed in 6.0.13r13 CWE-125
Priority LOW 25

Varnish Cache before 7.6.3 and 7.7 before 7.7.1, and Varnish Enterprise before 6.0.13r14, allow client-side desync via HTTP/1 requests, because the product incorrectly permits CRLF to be skipped to delimit chunk boundari…

CVSS 3.1MEDIUM 5.4 Network No auth No interaction EPSS 0.00367 Published 2025-05-13 Fixed in 6.0.14 LTS, 7.6.3 +1 CWE-444
Priority LOW 12

In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL.

CVSS 4.0LOW 2.3 Network Low privileges No interaction EPSS 0.00358 Published 2026-09-18 Fixed in 9.0.2, 9.0.4 CWE-787
Priority LOW 12

In Vinyl Cache before 9.0.1 and Varnish Cache before 9.0.3, a deficiency in HTTP/2 request parsing can be exploited to launch a backend request desync attack (request smuggling), which in turn can be used for cache poiso…

CVSS 4.0LOW 2.3 Network No auth User interaction EPSS 0.00382 Published 2026-06-03 Fixed in 9.0.1, 8.0.2 +2 CWE-444
Open these records in search →