Read the docs
TI-2026-29389 Aliases CVE-2026-40720GHSA-2p3v-427c-rpc7

WordPress Royal Elementor Addons Pro plugin < 1.7.1041 - Cross Site Scripting (XSS) vulnerability

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Unauthenticated Cross Site Scripting (XSS) in Royal Elementor Addons Pro < 1.7.1041 versions.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00175 7th percentileScored 2026-11-07
Fix Fixed Royal Elementor Addons Pro (Royal Elementor Addons): 1.7.1041

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wproyalRoyal Elementor Addons Probefore 1.7.10411.7.1041Patch availableCNA
  • Royal Elementor Addons Pro Vendorwproyal Affected before 1.7.1041 Fixed in 1.7.1041 Patch available CNA

Remediation

  • Fix · CNA Royal Elementor Addons Pro (Royal Elementor Addons) Fixed in 1.7.1041

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-40720
  2. 2026-10-03 Alias added: GHSA-2p3v-427c-rpc7

References

  • TI-2023-04933 Royal Elementor Addons and Templates < 1.3.79 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
  • TI-2023-05454 Royal Elementor Addons and Templates < 1.3.81 - Unauthenticated Arbitrary Post Read CVSS 3.1HIGH 7.5
  • TI-2022-03751 Royal Elementor Addons < 1.3.56 - Subscriber+ Arbitrary Post Creation CVSS 3.1MEDIUM 4.3
  • TI-2024-01463 Royal Elementor Addons and Templates <= 1.3.94 - Unauthenticated Limited File Upload CVSS 3.1CRITICAL 9.8
  • TI-2024-21660 WordPress Royal Elementor Addons and Templates plugin <= 1.3.93 - IP Bypass vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2022-03750 Royal Elementor Addons < 1.3.56 - Subscriber+ Arbitrary Post Deletion CVSS 3.1LOW 3.1
See all 98 →

Sources