Read the docs
TI-2026-29645 Aliases CVE-2026-40994GHSA-gg9r-wr4p-w63h

Wss4jSecurityInterceptor disables WS-I BSP validation by default

Priority MEDIUM 41CWE-1188Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Wss4jSecurityInterceptor initialized its BSP (WS-I Basic Security Profile) compliance flag so that inbound validation disabled WSS4J BSP enforcement on RequestData. Services that validate WS-Security on the network could therefore accept messages that violate BSP rules, weakening protocol-level checks. Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00229 13th percentileScored 2026-11-07
Fix Fixed Spring Web Services (Spring): 5.0.1.1, 4.1.3.1, 4.0.19 +1org.springframework.ws:spring-ws-security (Maven): 5.0.2, 4.1.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
VMwareSpring Web Services5.0.0 to before 5.0.1.1; 4.1.0 to before 4.1.3.1; 4.0.0 to before 4.0.19; 3.1.0 to before 3.1.95.0.1.1, 4.1.3.1, 4.0.19, 3.1.9Patch availableCNA
—org.springframework.ws:spring-ws-security (Maven)5.0.0 to before 5.0.25.0.2Patch availableGHSA-gg9r-wr4p-w63h
—org.springframework.ws:spring-ws-security (Maven)4.1.0 to before 4.1.44.1.4Patch availableGHSA-gg9r-wr4p-w63h
—org.springframework.ws:spring-ws-security (Maven)4.0.0 – 4.0.18—No fix listedGHSA-gg9r-wr4p-w63h
—org.springframework.ws:spring-ws-security (Maven)3.1.0 – 3.1.8—No fix listedGHSA-gg9r-wr4p-w63h
  • Spring Web Services VendorVMware Affected 5.0.0 to before 5.0.1.1; 4.1.0 to before 4.1.3.1; 4.0.0 to before 4.0.19; 3.1.0 to before 3.1.9 Fixed in 5.0.1.1, 4.1.3.1, 4.0.19, 3.1.9 Patch available CNA
  • org.springframework.ws:spring-ws-security (Maven) Vendor— Affected 5.0.0 to before 5.0.2 Fixed in 5.0.2 Patch available GHSA-gg9r-wr4p-w63h
  • org.springframework.ws:spring-ws-security (Maven) Vendor— Affected 4.1.0 to before 4.1.4 Fixed in 4.1.4 Patch available GHSA-gg9r-wr4p-w63h
  • org.springframework.ws:spring-ws-security (Maven) Vendor— Affected 4.0.0 – 4.0.18 Fixed in — No fix listed GHSA-gg9r-wr4p-w63h
  • org.springframework.ws:spring-ws-security (Maven) Vendor— Affected 3.1.0 – 3.1.8 Fixed in — No fix listed GHSA-gg9r-wr4p-w63h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:broadcom:spring_web_services:*:*:*:*:*:*:*:*before 3.1.9; 4.0.0 to before 4.0.19; 4.1.0 to before 4.1.3.1; 5.0.0 to before 5.0.1.1VulnerableBroadcom
  • cpe:2.3:a:broadcom:spring_web_services:*:*:*:*:*:*:*:* Versions before 3.1.9; 4.0.0 to before 4.0.19; 4.1.0 to before 4.1.3.1; 5.0.0 to before 5.0.1.1 Vulnerable ·Broadcom

Remediation

  • Fix · CNA Spring Web Services (Spring) Fixed in 5.0.1.1, 4.1.3.1, 4.0.19, 3.1.9
  • Fix · GHSA-gg9r-wr4p-w63h org.springframework.ws:spring-ws-security (Maven) Fixed in 5.0.2 Advisory →
  • Fix · GHSA-gg9r-wr4p-w63h org.springframework.ws:spring-ws-security (Maven) Fixed in 4.1.4 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Spring Web Services 3.1.9, 4.0.19 and 2 more versions

    7 records Highest priority Priority MEDIUM 3 MEDIUM, 4 LOW

    Other records, highest priority first

    • TI-2026-29650 Spring WS SSRF via unvalidated WS-Addressing reply destinationsPriority MEDIUM 43
    • TI-2026-29649 Jaxp13 XPath XXE via StreamSource and SAXSourcePriority MEDIUM 42
    • TI-2026-29648 SOAP security faults leak Spring Security account statePriority LOW 30

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat Fuse 7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-40994
  2. 2026-10-03 Alias added: GHSA-gg9r-wr4p-w63h
  3. 2026-10-09 Affected versions changed · Red Hat

References

  • TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
See all 1181 →

Sources