Read the docs
TI-2026-30290 Aliases CVE-2026-41887GHSA-xjvc-pw2r-6878

Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)

Priority MEDIUM 56CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.

Summary

Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00472 41st percentileScored 2026-11-07
Fix Fixed framework (flarum): 1.8.16, 2.0.0-rc.1flarum/core (Packagist): 1.8.16, 2.0.0-rc.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
flarumframeworkbefore 1.8.16; 2.0.0-beta.1 to before 2.0.0-rc.11.8.16, 2.0.0-rc.1Patch availableCNA
—flarum/core (Packagist)before 1.8.161.8.16Patch availableGHSA-xjvc-pw2r-6878
—flarum/core (Packagist)2.0.0-beta.1 to before 2.0.0-rc.12.0.0-rc.1Patch availableGHSA-xjvc-pw2r-6878
  • framework Vendorflarum Affected before 1.8.16; 2.0.0-beta.1 to before 2.0.0-rc.1 Fixed in 1.8.16, 2.0.0-rc.1 Patch available CNA
  • flarum/core (Packagist) Vendor— Affected before 1.8.16 Fixed in 1.8.16 Patch available GHSA-xjvc-pw2r-6878
  • flarum/core (Packagist) Vendor— Affected 2.0.0-beta.1 to before 2.0.0-rc.1 Fixed in 2.0.0-rc.1 Patch available GHSA-xjvc-pw2r-6878

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:flarum:flarum:*:*:*:*:*:*:*:*——flarum
  • cpe:2.3:a:flarum:flarum:*:*:*:*:*:*:*:* Versions — — ·flarum

Remediation

  • Fix · CNA framework (flarum) Fixed in 1.8.16, 2.0.0-rc.1
  • Fix · GHSA-xjvc-pw2r-6878 flarum/core (Packagist) Fixed in 1.8.16 Advisory →
  • Fix · GHSA-xjvc-pw2r-6878 flarum/core (Packagist) Fixed in 2.0.0-rc.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-41887
  2. 2026-10-03 Alias added: GHSA-xjvc-pw2r-6878

References

  • TI-2021-12339 XSS vulnerability with translator CVSS 3.1CRITICAL 10.0
  • TI-2023-08736 Post mentions can be used to read any post on the forum without access control CVSS 3.1HIGH 7.7
  • TI-2025-20573 Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite CVSS 3.1MEDIUM 6.8
  • TI-2026-23739 flarum/nickname: Display name injection in notification emails (autolink & markdown) CVSS 3.1MEDIUM 4.6
  • TI-2026-28792 Flarum < 1.8.16 Password Reset Token Expiry Bypass via POST /reset CVSS 4.0CRITICAL 9.2
  • TI-2022-20279 Cross site scripting vulnerability with discussion titles in flarum CVSS 3.1CRITICAL 9.0
See all 19 →

Sources